powered by Jive Software

Openfire 3.7.1, TLS/SSL, miranda and windows 7

Hi.

I’m using openfire for a really long time (and it rocks).

I was recently using a 3.6.4 version because of it’s stability and because of some issues in 3.7.0, waiting for a more stable version to come out.

But last week I had to upgrade the physical server the openfire was ran on, so I installed a 3.7.1 version.

Suddenly I discovered that all of my miranda clients (versions 0.8.x and 0.9.x) that are launched under windows 7 are unable to login: they hang indifinitely after the connection. No errors com up in the error log.

This can be easily solved by disabling the encryption (uncheck all of the SSL/TLS checkboxes).

Can this isssue be investigated or debugged ?

I would provide more data, but I just don’t see thae way to collect it (I guesss you guys aren’t interested in pcap captures).

I’m posting this issue here and not in miranda’s forum because I think this is openfire issue, because in 3.6.4 same clients were working with TLS.

I tried other clients - like psi, or miranda under windows xp or win2003s - all is fine as usual.

I will be glad to hear any ideas.

One more - I tried to use your JIRA and discovered that I cannot create new issues there. Is JIRA to Ignite Realtime developers only ?

Thanks.

I had the same problem. Old miranda (jabber plugin) cannot connect using TLS if installed at Windows 7. Windows XP is ok. Updating miranda to the last release (and jabber plugin) solved this problem.

Also here is some info: http://www.jabber.org/2010/02/service-update-2010-02-16/

1 Like

Eugene M. Zheganin wrote:

Is JIRA to Ignite Realtime developers only ?
Yes. It works like that. Users report issues in the forums and a few dedicated users file tickets.