OpenFire 3.7 and LDAP Authentication

I upgraded my server to OpenFire 3.7 from 3.6.4.

I have also updated my LDAP server to Samba3.

I can no longer connect to the LDAP server.

In the Profile Settings, I can complete step 1 fine. In step 2, when I tell it to test, I get an error say that no users are found.

My base dn is :ou=people,dc=xxxx,dc=com

Each user under the ou=people, is set as uid=username. This is an OpenLDAP server that we use for Samba to authenticate against and that all works fine.

When I test the connection here, the error comes up.

I am sure I am doing something foolish, but just not sure what.

Hopefully someone can help me,



Haha. It was something stupid. I forgot to change the name of the LDAP server to the correct one from the test one. BAH!!!

So That works now. I can see the users, etc.

Problem I have now, is when I set up the Administrative users. It fails on the password.

I don’t get anything in /opt/openfire/logs (ie. no file has changed in there), so I don’t know what is wrong.

Any help is appreciated.



Has the Server Name changed? (can be found on the Server page of the Openfire Admin Console)

Under Server > System Properties what does the Property Name admin.authorizedJIDs have as the Property Value?

Does the @ part of the admins listed there match the Server Name?

This is from the main setup of the server, so I can’t see the admin.authorizedJIDs property value.

I can see the list of users when I do the test from step 2 of the LDAP setup. I can set an admin user (if I type a name wrong, it does tell me, so I am guessing LDAP lookups are working), but when I test the user with the correct password for that user, it says that the password is wrong.



Hmm… This is weird. It works with another account, just not the one I want to use as the admin account.

What I have determined though, is if I change the password of an account in our LDAP system, openfire will authenticate with the old password, not the new one.

I told OpenFire to continue using the different account for admin, but after I login to the console, I get a blank webpage. Trying to reload the page, I still get a blank screen. I restarted the OpenFire service, still a blank screen.

Looking at the nohup.out log file, it seems that some plugins I had loaded in the 3.6.4 version, are either missing or not starting correctly in 3.7. Is there a way I can just remove all plugins from a command line or by editing a file?



OK. Turns out it was the Kraken plugin that was screwing me up. I eventually just removed and reinstalled OpenFire.

I have it now connecting properly to my LDAP server. Issue I have is with passwords. It does not seem to be reading the correct field for the password.

Case in point, I have an account that says the password is wrong, but I can login to Windows with that same credentials (Windows uses our LDAP server for authentication).

Another acount, I changed the password, but I OpenFire allows me to authenticate with the old password not the new password.

I am using Samba3 on our LDAP server, so not sure if a field has changed in that that OpenFire is not aware of?

Hope you can help,