powered by Jive Software

Openfire 3.9.1 external connection stoped working

Hello.

Please help.

I upgraded Openfire from previous version to 3.9.1. My external client acces stoped working. My server servername.domain.local cant be accesed by by client using servername.domain.com

“Can’t connect to server: invalid name or server not reachable”

Spark gives this warn:

XMPPError connecting to servername.domain.com:5222.: remote-server-error(502) XMPPError connecting to servername.domain.com:5222.

– caused by: java.net.ConnectException: Connection refused: connect

at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:524)

at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:953)

at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:1009)

at org.jivesoftware.LoginDialog$LoginPanel.access$1200(LoginDialog.java:219)

at org.jivesoftware.LoginDialog$LoginPanel$4.construct(LoginDialog.java:730)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:141)

at java.lang.Thread.run(Unknown Source)

Nested Exception:

java.net.ConnectException: Connection refused: connect

at java.net.PlainSocketImpl.socketConnect(Native Method)

at java.net.PlainSocketImpl.doConnect(Unknown Source)

at java.net.PlainSocketImpl.connectToAddress(Unknown Source)

at java.net.PlainSocketImpl.connect(Unknown Source)

at java.net.Socket.connect(Unknown Source)

at java.net.Socket.connect(Unknown Source)

at org.jivesoftware.smack.proxy.DirectSocketFactory.createSocket(DirectSocketFacto ry.java:28)

at org.jivesoftware.smack.XMPPConnection.connectUsingConfiguration(XMPPConnection. java:512)

at org.jivesoftware.smack.XMPPConnection.connect(XMPPConnection.java:953)

at org.jivesoftware.LoginDialog$LoginPanel.login(LoginDialog.java:1009)

at org.jivesoftware.LoginDialog$LoginPanel.access$1200(LoginDialog.java:219)

at org.jivesoftware.LoginDialog$LoginPanel$4.construct(LoginDialog.java:730)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:141)

at java.lang.Thread.run(Unknown Source)

Look at your Openfire log, maybe there has been an error.

There are no errors or warnings in openfire log connected to the issue.

It seems that the port is not open, or a firewall blocks access. Do the logs report that port 5222 is open?

Jak pokazał firmware w routerze był zepsuty. Myślałem, że porty były otwarte. Nie mogłem w to uwierzyć. Byłem pewien że wszystko jest ustawione w porządku.