powered by Jive Software

Openfire 3.9.3 Installation Problem (Debian/Java)

I’m facing a few problems with .deb of Openfire Setup.

This is how I setup Java (sry, cannot find tag):

Target Folder

mkdir -p /usr/lib/jvm/

tar xvf jdk-7u55-linux-x64.tar.gz

mv jdk1.7.0_55 /usr/lib/jvm/

tar xvf jdk-8u5-linux-x64.tar.gz

mv jdk1.8.0_05 /usr/lib/jvm/

Config (either/or)

JAVA_VERSION=“jdk1.7.0_55”

rm -f /usr/lib/jvm/latest

ln -s /usr/lib/jvm/$JAVA_VERSION /usr/lib/jvm/latest

update-alternatives --install “/usr/bin/java” “java” “/usr/lib/jvm/latest/bin/java” 1

update-alternatives --install “/usr/bin/javac” “javac” “/usr/lib/jvm/latest/bin/javac” 1

update-alternatives --install “/usr/bin/javaws” “javaws” “/usr/lib/jvm/latest/bin/javaws” 1

update-alternatives --config java


However:

java version “1.7.0_55”

Java™ SE Runtime Environment (build 1.7.0_55-b13)

Java HotSpot™ 64-Bit Server VM (build 24.55-b03, mixed mode)

results while setting up OF 3.9.3 in:

dpkg: regarding openfire_3.9.3_all.deb containing openfire, pre-dependency problem:

openfire pre-depends on sun-java6-jre | default-jre-headless | openjdk-6-jre | openjdk-7-jre | oracle-java7-jre

sun-java6-jre is not installed.

default-jre-headless is not installed.

openjdk-6-jre is not installed.

openjdk-7-jre is not installed.

oracle-java7-jre is not installed.

dpkg: error processing openfire_3.9.3_all.deb (–install):

pre-dependency problem - not installing openfire

Errors were encountered while processing:

openfire_3.9.3_all.deb

I’ll use now use the .tgz, as I would not like to setup Java over sources.list/repos/whatever.

Maybe the control file of .deb needs an rework?

Thanks!

Since there are many user/folder/pathes etc in deb, I’ve installed the .deb like this:

DEB=“openfire_3.9.3_all.deb”

TGT=“of393”

dpkg-deb –x $DEB $TGT

dpkg-deb -e $DEB $TGT/DEBIAN

Modifying “control” file and removing line:

Pre-Depends: sun-java6-jre | default-jre-headless | openjdk-6-jre | openjdk-7-jre | oracle-java7-jre

dpkg-deb -b $TGT of393_nojavacheck.deb

Party time

dpkg -i of393_nojavacheck.deb

(Reading database … 38417 files and directories currently installed.)

Unpacking openfire (from of_rebuild_393.deb) …

Setting up openfire (3.9.3) …

adduser: Warning: The home directory `/var/lib/openfire’ does not belong to the user you are currently creating.

best java alternative in: /usr/lib/jvm/latest

Starting openfire: openfire.

Perfect.

Hi,

I don’t know if this will help, but since I found this via Google, it might help others.

I had a problem installing v3.9.3 on Ubuntu 12.04 LTS. It was a simple, but easy to miss problem. First, I tried uninstalling a previous version of OpenFire using the Software Center app. It seemed to work, but of coarse didn’t when I tried to install the latest version. What did work is to use “apt-get purge openfire” and then reboot the system. This did a better job of clearing the appropriate files apparently (the reboot I think).

So that got me closer. Next, I had to change the permissions on the “var/run/opensite.pid” file so OpenFire could write to it. I think this was a consequence of an update to Ubuntu which seemed to make all imported files require more direct permission settings. Neither problem seemed to cause an actual error, but once I did the above, OpenFire started right up with the usual “service openfire start”.