powered by Jive Software

Openfire 4.0.0 Beta

By the way, in current beta version they must forgot to mention default password is ‘admin’ or put incorrect check.

Not sure what you mean exactly by forgetting or incorrect check. Just tried a clean installation and it does sets password to ‘admin’ if you skip the step. I don’t remember it behaving differently in previous versions. Anyway, i have filed a ticket to clarify this a bit and proposed a patch [OF-1016] Add explanation to setup about default admin password - Jive Software Open Source

Though i can’t understand why it is so hard to actually setup some password on that form during your first installation. This page (Admin account) is constantly updated and clarified, though it was super clear for me when i first installed Openfire. Some admins need to practice reading before hitting Next automatically…

Hi,

I retry that but not work for me. How can remove completely my previous install and uninstall files for install new. because i uninstall that so many by command:

sudo apt-get --purge remove openfire

Hi Wroot,

At the time of first installation, is showing current password ‘admin’ is incorrect.

@Saeed: To install again just go to openfire.xml in (conf/) directory and check true. Just make it to false and hit the url on browser again. You will get setup page.

aks, i have ran new installation of 4.0.0 beta a few times already and it doesn’t show a field “current password”. It will show it only when you try to install Openfire on top of already installed installation.

Yeah my fault. But, in OF 4.0.0 is showing default password ‘admin’ is not correct.

Can you provide a screenshot of what you mean? Still having hard time to grasp where you see it showing. For a new installation admin IS the default password if you skip the setting up admin password step. Tested this yesterday a few times.

yeah, if we skip the setting up admin password step then it wouldn’t shown. If you setup your own password and click upon ‘Continue’ button then it is showing error message.

@saeed : Can you share the screenshot what error are you getting exactly. Although I was getting earlier but after skip the admin password setting up step now it’s working fine.

Hi @aks

OFError2.JPG

this is my screenshot. I have before OF 3.10.3 but before i install OF 4.0.0 Beta i’d removed OF 3.10.3 but I can’t install yet. thank’s of your resposibility

This is obviously not the new installation. As new installation doesn’t ask for Current password. You have removed 3.10.3, but not completely. You still have config and the database left. If you want to do a clean install, then delete those left over files (if you don’t need you old database).

Hi there,

I remove openfire with command: sudo apt-get --purge remove openfire and delete database but i don’t know is there any file of openfire for delete? if there is where is file to delete?

Hi.

Try:

sudo find / -name “openfire

and then delete all these Directorys.

Thank’s that worked!