powered by Jive Software

Openfire 4.0.0 Released

Just wanted to let you know that i have just updated from 3.10.3 to 4.0.0 (embedded database, self-signed certificates generated by Openfire, ~200 Spark clients). Everything went smoothly. No Admin Console login problems, TLS works, clients can connect. I needed to update just one plugin - ClientControl (i use only 3 plugins) and it updated via Web UI without a problem. Good so far.

Wroot, what upgrade process did you go through?

Does the Ignite Realtime feed work in the 4.0 admin console?

Is the upgrade process as easy? We just went from 3.10.2 to 3.10.3 and only needed to overwrite a few files (as has been the case for the last couple of upgrades).

Thanks,

SG

Windows. Just ran the installer and let it update the installation. I then usually reinstall the service, though it most probably not needed.

@spacegoose Yeah the feed does now finally work in the new console

Upgrading was easy enough on Linux - I downloaded the RPM and just ran yum update <openfire-4.0.0.rpm> and it all updated

From some other comments the Windows update is just a case of running the MSI/EXE to update the system

Gatt

Thanks for debugger plugin

Very good

Plz add search muc in option search plugin

Please note that if you plan to use Openfire Meetings with Openfire 4.0, you would need version 0.3.x which is available in source from community plugins on GitHub. The binary for OF 4.0 is not yet built.

Version 0.2.x on the plugins page will not work with Openfire 4.0. A change to MUC presence handling has broken it.

Thanks for the info!

Fixed it!

Turned out to be a dodgy keystore! No signs it was corrupted, but creating a new keystore has resolved the issue!

Not sure what went wrong with the keystore though…

This maybe [OF-1049] Improve Certificate Store Management - Jive Software Open Source

@spacegoose Please note that simply replacing “a few files” is not a supported or recommended upgrade path.

You’re likely to run into problems this way when upgrading to 4.0.0. A lot of libraries changes were applied. You’re also running the risk of having old files that should no longer be there.

I’d advise you to follow the standard upgrade procedures that are applicable to your environment. And be sure to create a backup before you start.

Please the installation 4.0.0 is tormenting me o! It shows me that error (unpacking of archive failed…)

during installation. And then when I exceute ‘service openfire stop’

after setup, it still takes me back to resetup the server all over again. I have done this many times still it repeats. I need a solution please

USING

CentOS 6 + CPANEL

Thank you so much!

Also I tried ‘rpm -Uvh --force openfire-4.0.0-1.i386.rpm’ too but got the same result

You could be having disk errors, check your system logs to verify if errors extends to other parts of your system, if is necessary restart system and use fsck if needed.

If everything is fine, download again the rpm file and try reinstalling it, maybe is just the file that is corrupt, my system shows a size of 93M for the file

ls -lh openfire-4.0.0-1.i386.rpm

-rw-r–r-- 1 root root 93M Jan 11 08:32 openfire-4.0.0-1.i386.rpm

Bye

I follow the upgrade instructions. They pretty much say to copy over a few files (if I’m not hallucinating ). I am referring to the 3.9.x to 3.9.y upgrades, not 4.x.

Regards,

sg

We’ve just released Openfire 4.0.1, which addresses many of the issues that were raised here. Give it a try!

1 Like

Ok. Thank you so much! Let me try what you said.