powered by Jive Software

Openfire 4.0.2 .deb dependency issue on Debian 8 Jessie


#1

Hello guys,

The openfire_4.0.2_all.deb still depends on

openjdk-7-jre-headless | openjdk-7-jre | oracle-java7-jre

but 4.0.2 actually needs openjdk-8 (or it fails with java.lang.NoSuchMethodError: java.util.concurrent.ConcurrentHashMap.keySet()Ljava/util/concurrent/Concurrent HashMap$KeySetView;)

I installed openjdk-8-jre-headless from jessie-backports, but the openfire init.d script still selects openjdk-7 as the “best” alternative, and openjdk-7 cannot be uninstalled since openfire still depends on it.

The workarounds I found were either edit the init.d script to force the use of openjdk-8 or (which I did) edit /var/lib/dpkg/alternatives/java to make the priority for openjdk-8 higher than openjdk-7.

The dependency needs to be updated.

Thanks!

Joao


#2

Should be fixed in 4.0.3 [OF-1115] Deb package shouldn’t require Java 7 dependency - Jive Software Open Source