powered by Jive Software

Openfire 4.0.2 Released

Hello. I have a question about Spark. Suppose I am in a room. I click on a person and get to a chat with him inside a room. However I’d like to get to a regular chat-to-chat when licking on a person.

hi openfire team

i use this application for windows server and i have many problem with flooders and spam softs

my server is hanging and down probably under flooding rooms and use many server ram and cpu

please add new features for anti room flood, add flood and etc

for exm: set time between 2 message for users in room or in addlist. And set times between 2 join left from room. And time between 2 add request for avoiding down server

tnx a lot

i waiting for new version of openfire

I am sorry to hear about your flooding problems. Are you aware that you can apply IP-based restrictions? Perhaps that will offer a solution for you. This configuration can be applied in the admin console, tab “server”, subtab “server settings”, menu-item “registration & login”.

1 Like

unfortunately this offer not answered completely for avoiding floods.

everyone can use this destructive softs and it hard to recognizing all flooders and block one-to-one users ip

if this options can be added to new version is better and necessary

it is big problem for everyone who has openfire server, please more think for us

it may added enter captcha feature for joining room in future?

Is there any differences and/or caveats between running it on Windows or Linux (Ubuntu) in an Active Directory environment? From my testing on the Windows version it seems that the AD integration is completely being handled by Openfire.

Same Problem here after Update to 4.0.2 with Java 1.7…

Updatet Java to 1.8… (How To Install Oracle Java 8 In Debian Via Repository [JDK8] ~ Web Upd8: Ubuntu / Linux blog)

After that i cant connect to the admin Interface… and Spark doesnt connect too.


Java - version:

java version “1.8.0_77”

Java™ SE Runtime Environment (build 1.8.0_77-b03)

Java HotSpot™ Client VM (build 25.77-b03, mixed mode)

“Connection Refused” can mean anything. Are you sure that the Openfire process is running? Anything in the logs?

hmmm no openfire process in top…

sudo /etc/init.d/openfire start

best java alternative in: /usr/lib/jvm/java-8-oracle/jre

Starting openfire: openfire.

but no process “openfire” in top…?!


Could you please let us know the supported SQL Server version?

The place I work has a standard for SQL Server implementation. Could you please confirm if any of the following versions are supported: SQL Server 2008 R2 / SQL Server 2012 / SQL Server 2014?

Thanks and regards,


We have no other information available other than what is listed here: Openfire: Database Installation Guide

upgraded now from version 3.9.3 and all went well.

I have upgraded version by version to make sure everything was going to work well.

Thanks for the great job