powered by Jive Software

Openfire 4.0.3 dep on default-jre-headless?

I just tried to upgrade Openfire from 4.0.2 to 4.0.3 on a Ubuntu 14.04 box, and got a pre-dep error for missing default-jre-headless “>=1.7.0”. Why has this dependency been added? On Ubuntu 14.04 the default-jre-headless package is 1.6.0, and hence does not satisfy the requirement. I generally use the webupdteam’s oracle java launchpad PPA to install java 1.7.0 - 1.9.0 as needed using the alternatives system, and the first thing to do on a new box is to make sure all the junk default-jre-headless installs have been *removed. *But now if I install 4.0.3 with --ignore-depends=default-jre-headless, every time I run apt-get update it fails unless the ignore-depends flag is added. So now I must have default-jre-headless package (and hence java 1.6.0) installed just to satisfy the dep while I start openfire with PPA-installed java 1.8.0.

Hello,

Sorry for the troubles. This will be corrected in the next release.

OF-1177 allow java7-runtime-headless to satisfy .deb requirement by akrherz · Pull Request #637 · igniterealtime/Openfir…

Will this change work for you?

Hi Daryl,

Yes, it seems that will fix it. I upgraded to 4.0.3 with default-jre-headless package temporarily installed (even though it’s not used), and I’ll remove it once the next release of Openfire comes out. Thanks for the reply!