powered by Jive Software

Openfire 4.0.3 using high amount of read IOPS

We have noticed our Openfire VM is very chatty specially on read (using 1400 IOPS) which is more than even our domain controllers. On average we have only have about 40 - 50 users logged in. Are there any settings we can look at disabling to make the application less drive intensive? It’s running on Ubuntu 16.04.

Please advise.

Thanks.

Which backend database are you using? Is Openfire pegging CPU with 1400 IOPS?

CPU and Memory are not being taxed and often quite low. It’s the built in integrated database. If there was a way to determine the excessive reads done on the disk (I suspect it’s reads to the database). Could it be a plugin? Just grasping at straws at this point.

On the admin console, go enable database query stats and see what’s causing the massive IOPS https://localhost:9091/server-db-stats.jsp

Note, production loads should always use a ‘real’ database server, like PostgreSQL, mysql, etc… The built in database is meant for debugging, testing, and ease of initial use.

Thank you. I enabled Query stats and can see the total number of operations is 700. Not sure what is consider “high” but I suspect it’s the constant queries to the database causing the high iops. Is it possible the application is not closing out database sessions and leaving them open?

It appears after we removed some of the unused plugins, the IOPS have gone down to normal. Not sure which plug in specifically might have been causing the issue but it doesn’t appear to be database related.