powered by Jive Software

Openfire 4.1.1 and Spark contacts issue

Hi all,

I have some issue regarding on openfire im client (built in from elastix 2.4) I’ll just upgrade openfire version from 2.7.1 to the newest 4.1.1 version. The issue is the lists/contacts from spark are not displaying properly. Thanks in advance.

You message is vague. What does “not displaying properly” mean? Also, take a look at a few threads below yours. Maybe your issue is similar to theirs. There is a link to a test build with possible fix there.

I am having a similar issue. Some users will log off and log back on then they will only see people in their department. The fix for now is going into the admin console and removing them from their group and re adding them. I would like to find a more permanent solution though.

What OS? You can try the test build with the possible fix:

Windows https://bamboo.igniterealtime.org/artifact/OPENFIRE-NIGHTLYWINDOWS/shared/build- 2342/Project-Windows-distribution-files/…

Debian https://bamboo.igniterealtime.org/artifact/OPENFIRE-NIGHTLYDEB/shared/build-2171 /Project-Debian-distribution-files/openf…

A server 2012 vm

is this easy to roll back if it has more issues?

There were only a few changes since 4.1.1, one of them for Oracle databases. So it shouldn’t be worse. But you can always uninstall and install lower version. Even 4.0.4, if that fix doesn’t work for you.

Correction. It seems that 4.1.1 had too many changes in the database structure, so you are stuck with 4.1.x versions now. You won’t be able to install 4.0.4, but you can still go back to 4.1.1.