powered by Jive Software

Openfire 4.1.1 LDAP Group and Users Issue

We just added a new Unix server running Openfire 4.1.1. We set it up using AD LDAP. The admin console populates with all of the groups and users listed in the active directory but the spark clients will not populate with the groups and users. I can manually add the groups and users if I manually add every single object (not an option.) I hope I’m just overlooking something easy. Anyone have any suggestions? Thanks.

you must enable roster sharing within openfire.

Users/Groups > Groups

Under Group Summary, find the group that you want to share as a roster and click it.

Under Contact List (roster) Sharing, enable, save contact list settings.

For future reference, there is no need to post the same issue 3 times. Thats poor form. By doing that, you resurrected some old threads, which isn’t good either.

1 Like

Hi there! I’m having the same problem on the version 4.1.1.

And we already have active sharing…But the user can only see his group and not the others…

Please…, any suggestion?

Thanks

When you are in group edit there is a warning that says “not allowed: the group account system is read only.” This is a little misleading. Speedy’s response is correct. Checkmark the “Share group with additional users> the following groups> select the groups> enter the Name of the group as you would like it to show in the client> save”

Thanks and sorry about that. I didn’t realize how old those two other threads were.

Ok, now all of my groups and users populated, only it pulled my entire AD. I created a new container, added an openfire access local security group, added an IM group, added my admin user to the group and the group to the openfire access group. I changed the base dn to point at the new container cn=users,cn=spark:dc=,dc=local - it looked fine, rebooted and now I’m locked out of the admin console. I have tried find and open the openfire.xml to change the setup parameter so I can start over, but I cant access/find the .xml.

Help please.

Ok. This works fine by sharing the groups manually. But before the update, if you selected All Users, it worked normally and we could see other groups in Spark. Now you can only view by manually sharing each group. This is laborious when you have to reinstall the system for example.

Any way… in this way it works…

Thanks

Also having this issue, has been working fine for over a year now just these past few weeks this has cropped up.