powered by Jive Software

Openfire 4.1.1 - Lost VCard information for users

I did a couple of things yesterday morning… not sure which could have caused the issue:

  • I upgraded Openfire from 4.0.3 to 4.1.1.

  • I added “PLAIN” to my sasl.mechs to resolve an issue where SSO from Active Directory worked fine, but users who did not log in using SSO were having trouble.

I have now lost all of my vcard mappings. A reboot of the Ubuntu server Openfire is hosted on (rather than just restarting the service) did not help.

Any ideas? Nothing else changed.

Thanks.

What is your “provider.vcard.className” system property? That’s the only recent thing i have found related to vCards [OF-1145] Avatar Resizer plugin issues when using LdapVCardProvider - IgniteRealtime JIRA

Good catch. It was set to the resizer plugin… even though I am not using avatars in the system. I may have installed that a while back when we initially discussed the possibility of adding avatars.

After deleting the plugin, it’s now set to “org.jivesoftware.openfire.vcard.DefaultVCardProvider”

I’ll restart the server after hours and see if that helps. Thanks!

Rebooted the server - I’m still not getting any vcard info.

Is there anywhere that I can view errors related to this? I’m not seeing anything in the logs that are viewable from the console.

Ugh - needed to change the provider.vcard.className to “org.jivesoftware.openfire.ldap.LdapVCardProvider”.

I think I have it working… Thanks for pointing me in the correct direction!