powered by Jive Software

Openfire 4.1.5 vCard problem

Hello,

I have an Openfire installation on live server and I cannot see vCards for any member/user. This installation is from an update of previous version but even before update I could not see vCards.

I have installed on a development server the same version of Openfire and the vCards are there with all details (name, job, phones and even employee photo).

I have reinstalled over it the same version as an update, the vCards are still present.

Now my question is, since I checked all settings/properties and all are the same, why I cannot see the vCards on live server?

Thank you in advance

check you system properties and look for provider.vcard.className and compare that to the server that works.

Hi,

Thank you for your response.

I did replace “provider.vcard.className” with “org.jivesoftware.openfire.ldap.LdapVCardProvider” but I think that I do not have the .jar in my Openfire folders. Where I can search it?

It was indeed the “provider.vcard.className” but it was set correctly;

To solve the problem I did the following:

  1. I installed the “Avatar Resizer” plugin and that change my “provider.vcard.className” to something else.

  2. I uninstalled the “Avatar Resizer” plugin and that change my “provider.vcard.className” to default vCard provider;

  3. I change “provider.vcard.className” to “org.jivesoftware.openfire.ldap.LdapVCardProvider” ;

  4. restart Openfire service.

  5. After each client re-login, the vCards were OK.

There is a ticket for that [OF-1145] Avatar Resizer plugin issues when using LdapVCardProvider - IgniteRealtime JIRA

Thank you both wroot and speedy.

I had this issue since a few Openfire versions ago but now I wanted to fix it and since a new clean installation was working just fine on the same Openfire version and since I replaced provider.vcard.className to use LDAP provider and still no vcard data I was out of ideas.

Searching on Openfire forums I found a thread about “Avatar Resizer” plugin problem and I said to gave it a try. Fortunately for me it worked that way.

Best regards,