powered by Jive Software

Openfire 4.2.2 with Monitoring Service 1.5.9 unicode

You can temporarily change language to English and check what it shows then.

Снимок

That’s weird. Can you show or lost what plugins you have installed?

That’s all, I figured it out. This problem with encoding is observed in the plugin “Search”

Search works fine for me in both Russian and English. Not sure what is happening. Maybe it’s your OS or region, don’t know.

I do not know. Problems with the encoding in the plug-ins “Search” and “Monitoring” appeared after the upgrade to the version of Openfire 4.2.2. The search plugin is not important to me, but I hope the monitoring plugin will fix it on this request https://issues.igniterealtime.org/browse/OF-1500 . Especially such a problem is observed not only in me
By the way, if you change the language to English, problems with the encoding in the “Monitoring” plug-in remain. I think it’s not a language

Actually it started with 4.2.1, but you probably skipped that version. For 4.2.1 one contributor has updated whole Russian translation (https://issues.igniterealtime.org/browse/OF-1452). Before that it was needed to replace every non-latin character in translation with unicode code like \u012e. So one developer has changed the encoding of some translation files, so it could be edited just in Russian https://issues.igniterealtime.org/browse/OF-1448. But only main translation files were encoded. All plugins stayed untouched, yet that contributor has translated them in Russian, so they show garbled now.

I have filed a ticket to encode all other files recently, but it haven’t get attention yet https://issues.igniterealtime.org/browse/OF-1517

Though it doesn’t explain why you still see them garbled when using English. That i don’t know why.

Hello.
I think reason in server environments or in browser. It detect russian settings and uses related translation file no matter which settings done in OF itself.
For me quick fix was to rename /opt/openfire/plugins/monitoring/i18n/monitoring_i18n_ru_RU.properties file.
This falled back to default translation for plugin. (I use English settings on OF web console).

This file looks like encoded correctly - in utf8.
So I think here two bugs:
1 - bug in detect env of server/browser and not using OF settings
2 - display russian translation in web console. maybe some reencoding while display translation… don’t know

PS
to get correct display we need to do “ISO-8859-1 > UTF-8” with text. Not with translation file content, but with that, what displayed in web console.
I use OF 4.2.3

2 Likes

Так что итоге что нужно сделать, чтобы кодировка отображалась нормально? Спасибо

I guess to wait for some of the developers to take a look at this.

Проблема решается следующим способом!

mv /usr/share/openfire/plugins/monitoring/i18n/monitoring_i18n_ru_RU.properties /usr/share/openfire/plugins/monitoring/i18n/monitoring_i18n_ru_RU.properties.bak

cp /usr/share/openfire/plugins/monitoring/i18n/monitoring_i18n.properties /usr/share/openfire/plugins/monitoring/i18n/monitoring_i18n_ru_RU.properties

service openfire restart

1 Like

Well, in that case you will have English menus. It is better than unreadable characters, but not a proper solution. A workaround. One can also switch whole GUI to English language in the settings.

Даже если переключить графический интерфейс на английский проблема не уйдёт.
Плагин смотрит не на сервер OPENFIRE, а на саму операционную систему точнее её локализацию и пытается кривой кодировкой ISO-8859-1 что-то перевести на русский.

Interesting. As my region is not in the list of possible languages, it is not trying to apply localization automatically. So, you say that if you select English or some other language on the Language and Time Settings page it still shows all GUI in Russian. Or just for Monitoring plugin? In that case this looks like a bug in this plugin. I think it should obey the main selected language.

Да именно проблема в плагине, т.к. все остальные работают корректно.
Сервер OPENFIRE был установлен с английским языком и язык в админке тоже не менялся, как был английский так и оставался.
Я думаю не зря сюда об этой проблеме начали писать на русском языке.=))

What other plugins you have installed that show English menus correctly? Say, do you have Bookmarks plugin? Or can you install it to check if it will show English or Russian menus? It has Ru i18n file. But i think it should still show in English, if English is set as the main language.

Update: have filed another ticket for this https://issues.igniterealtime.org/browse/OF-1564

Update: a change has been merged to the current source code which should fix the garbled text issue https://github.com/igniterealtime/Openfire/pull/1174 but it will only work with a future release 4.3.0 of Openfire (not sure when it could be released).

To be exact: this fix will work only after the plugins have been build with the upcoming 4.3.0 release of Openfire. Many plugins will not actually require Openfire 4.3.0 to run.

1 Like

Спасибо тебе добрый человек.