powered by Jive Software

Openfire 4 with AD integration?

Hi, anyone is using openfire 4 with AD integration?

I’ve been using openfire for a long time, since version 4, i’m not able to share my groups as you can see at the picture:

Any help i will be glad, thanks.

if the groups are listed, than you just scroll down to the group and check “Enable Contact list group sharing” give it a contact list name, and that’s it. You can’t edit things like membership and the actual AD group name.

If no AD groups are listed, than you likely have a problem with your search filters or base dn

Hi, thanks for your reply, but i already tried this, there is groups that appears and others don’t, i have the same configuration running fine on openfire 3.9.1, i tried all those versions above, none of them works.

Groups - OK: (Openfire 3.9.1)

Groups - NOT OK (Openfire 4.1.4)

I’m not the unique having this problem, i saw another guy with the same problem.

try disabling, and then re-enable

Hi, i already tried. I was forced to downgrade to 3.9.1.

I have been using Openfire with AD Integration for many years, both on version 3 and version 4. Based on your screenshots, everything seems to be working properly. The “Not allowed” message is normal for LDAP groups and just means that you can’t edit the name or members of the group. You can still share the group, though.

Can you please provide more information about exactly what isn’t working? Thanks!

Hi, thanks for your tips, the problem appears on Spark, sometimes you can see all the groups i’m sharing sometimes not.

So far i’ve been using my database with postgres, so i did another installation using internal database, so far i didn’t had any problem.

I am glad the internal database is working for you! I am using the internal database as well but I don’t know why postgres would be any different. If you ever decide you want to go back to postgres you might try using Pidgin instead of Spark to see if it has the same issue. We have always used Pidgin with Openfire and been very happy with it.