powered by Jive Software

Openfire admin password

Hey,

I have a small problem, my openfire server has been running so well that I haven’t needed to administer it for a while and have forgotten the admin password. This would be fine if I was using MySql as it would be easy to fix, but I have used the built in database.

Would someone be able to give me a simple howto on how to reset this password.

Many Thanks

Find the sparkweb.xml file in the Conf directory, open it in your favorite text editor and place the following:

joe

Where “joe” is any user you want to use as the admin. This will allow you to login with an account you know.

If this doesn’t work, open the same sparkweb.xml file, find the entry near the bottom that says true and change it to false.

Stop and start the service, open the admin console and you will be prompted to begin the setup again. You previous settings will be saved and you can press “save & continue” for most settings. When it asks for the admin account, fix it there.

1 Like

Hi,

I believe oxymoron meant to say openfire.conf , but I am not sure if that will work with the Openfire 3.6.0a release.

Another option is to launch the embedded-db-viewer.sh application from the bin/ folder and see about viewing the

ofUser table with that utility.

daryl

Oops, too early for my brain… Yes, I meant the openfire.xml file and yes, I have used it with 3.6.0a.

Ok.

embedded-db-viewer.sh only seems to work if you have x enabled which I don’t. Is there another way to change the database?

Many Thanks

Hi,

I am not well versed with the embedded database, but I believe in the embeded-db folder, there is a openfire.script file, which contains the SQL commands for your database. If you open it up with a text editor and search for a line containing admin and ofUser, you may find your password in plain text there.

daryl

I too am unable to access the web admin console. What happened to this feature compared to the older versions?

I don’t have the admin info listed in my openfire.xml file. any other ideas? Yes I am running the latest version. Just downloaded a couple days ago and set this up.

Thanks

Salt

With 3.6.0a, is it possible to add another authorized user to the openfire.xml file and have that new authorized user get sucked in to the database with a restart of openfire? (if it is, you could do that, get in and then start adjust admin user/passwords as needed).

As stated before, edit the conf/openfire.xml file with the red text…

*** jimuser *** 9090 9091

This will REPLACE the existing admin account.

Once you get into the Admin console, you can edit the Server Properties and change the admin account, or add another with a comma separator.

I have done this several times with 3.6.0a…

Hi,

This worked for me. Like many others I seem to have an Openfire server that keeps forgetting passwords.

version 6.3.6, about 3 days old. Not too impressed.

Hmmm,

I tried that on my 3.6.0a server and then went to the admin gui and typed jimuser with no password and it didn’t let me in. (I copied and pasted your text and then stopped and started openfire). We use ldap integration with AD normally so is it possible this didn’t work because it still tried to use ldap/ad for authentication? I’m basically looking for a way to get into the admin gui when the ldap/ad piece is hosed up so I can reconfigure to get it working.

Thanks

Been there, done that many times. If you brick your ldap configured server, you can’t just add an admin account to the openfire.xml to get access. If your ldap stuff is horqued, then it will not find the user you added to the xml file.

The only recourse is to change the true to false and restart your server. Reconnect and run through mr wizzard again.

jim

Helo Everyone,

I just installed Openfire for the first time. We have a Red Hat server, so I went with the openfire-3.6.4-1.i386.rpm. It installed fine with no errors. It started fine. I went to the browser interface and configured it fine. I chose to use the embedded database and default group system. However, when I went to log in it told me that my username or password were incorrect. I have tried the solutions offered on this thread and none of them have worked.

Interestingly, when I tried to run the embedded viewer I got this error:

root@server sh embedded-db-viewer.sh
Starting embedded database viewer…
Exception in thread “main” java.lang.NoClassDefFoundError: org.hsqldb.util.DatabaseManagerSwing
at gnu.java.lang.MainThread.run(libgcj.so.7rh)
Caused by: java.lang.ClassNotFoundException: org.hsqldb.util.DatabaseManagerSwing not found in gnu.gcj.runtime.SystemClassLoader{urls=[], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
at java.net.URLClassLoader.findClass(libgcj.so.7rh)
at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.7rh)
at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
at java.lang.ClassLoader.loadClass(libgcj.so.7rh)
at gnu.java.lang.MainThread.run(libgcj.so.7rh)

I made sure that I have gcc-java installed (4.1.2-48). Is there something else I need? Is my whole setup broken?

http://community.igniterealtime.org/message/205901 may help.

root@server sh embedded-db-viewer.sh
interesting, I would not start a java application as root

The error “Caused by: java.lang.ClassNotFoundException: org.hsqldb.util.DatabaseManagerSwing not found” indeicates that a “.class” or .“jar” file is missing to start the db viewer application, so it’s sad that you can’t start it but it does not hurt. Your database is so small right now, you can even view and edit it with “vi” (while Openfire is not running) if you want.

LG

where is the database file?

Openfire-Home/embedded-db/openfire.script (all changes/updates are in openfire.log if it does exists).

Not sure where the RPM file does install itself, /usr/local/jive/openfire may be possible.

LG

I openfire.xml appears in the administrator name … I add it?

That is what I get in my openfire.xml

<?xml version="1.0" encoding="UTF-8" ?>
  • <!--
This file stores bootstrap properties needed by Openfire.
    Property names must be in the format: "prop.name.is.blah=value"
    That will be stored as:
        <prop>
            <name>
                <is>
                    <blah>value</blah>
                </is>
            </name>
        </prop>     Most properties are stored in the Openfire database. A
    property viewer and editor is included in the admin console.

–>

  • <!--
root element, all properties must be under this element

–>

  • <!--
Disable either port by setting the value to -1

–>

9090

9091

es

  • <!--
Network settings. By default, Openfire will bind to all network interfaces.
      Alternatively, you can specify a specific network interfaces that the server
      will listen on. For example, 127.0.0.1. This setting is generally only useful
       on multi-homed servers.

–>

  • <!--
<network>
        <interface></interface>
    </network>

–>

org.jivesoftware.database.EmbeddedConnectionProvider

true

Strange… I could not log in to Admin Console even after your suggestions.

I’m using WAMP on localhost so I did this:

  1. Opened “openfire” database in PHPMyAdmin

  2. Opened “ofuser” table

  3. Found (at install time generated user) “admin”

  4. Edited cell in column (at install time created) “plainPassword

4a) New password was entered

  1. Login was successfull [username: admin / password: see 4a)]

Please do file a bug-report on this one.

N.B.

Since I’m running on localhost I do not have any certificates installed that should break the functionallity - or?

Hi Sasa,

did you test this with 3.7.0 beta?

LG

Hi!

Nopp - will firstly check out the non-beta sw.

/S

[Edit]

Yepp - now it works as it should.