powered by Jive Software

Openfire administration problem

i’m running openfire 3.6.3. on ubuntu 8.10. my machine specs - core2duo 1.8GHz, 2Gb DDR2 RAM. database engine is mysql5.

was using it admin console via admin account, add some test groups and users to it. then i download and install spark client. i tried to login from spark with my admin account - got error. then i logout from admin console and then i couldn’t connect neither through admin console or spark.

can i somehow reset admin account to its default state without messing up openfire database?


take a look at the resources/database/``openfire_mysql.sqlfile. Locate the line where “admin” is created.

INSERT INTO ofUser (username, plainPassword, name, email, creationDate, modificationDate)
    VALUES ('admin', 'admin', 'Administrator', 'admin@example.com', '0', '0');

Manually connect you your MySQL database, delete the user “admin” and create it again with the new values. The new password will be “admin”.


done this exactly as it said. nothing changed. message that i see - “Login failed: make sure your username and password are correct and that you’re an admin or moderator.”

solve this by recreating openfire database. still wanna find a correct answer


maybe you’d have to need to restart Openfire to make sure that the DB cache gets flushed.


tried that too - solves nothing

This generally occures when your permissions are not set correctly, either in mysql or the openfire install folder itself. The mysql db connection account should have full control of its database, and whatever ID you run openfire as should have full rights to the opefire folder and subfolder and files.

1 Like