Openfire and Ldap Groups

I am a new user to openfire and I’m having a lil trouble. I have openfire grabbing users from active directory with no problem. What I would like to do is use the “Groups” ou instead of the “Users” ou. I tried changing the base dn and it gave and error. I saw a thread in the forum and tried using a filter but for some reason it still only grabs the groups listed under the “Users” container. My filter is currently “OU=Groups,DC=company,DC=net” under the ldap.groupsearchfilter heading, and my ldap.searchFilter is “(objectClass=organizationalPerson)” . I know I’m making a simple mistake but i’ve tried all the different variations I could think of. Any help is greatly appreciated.

Extra Info:

ldap.baseDN cn=Users,dc=company,dc=net

ldap.adminDN cn=Administrator,cn=Users,dc=company,dc=net

provider.auth.className org.jivesoftware.openfire.ldap.LdapAuthProvider org.jivesoftware.openfire.ldap.LdapGroupProvider
provider.user.className org.jivesoftware.openfire.ldap.LdapUserProvider

You need to back off the baseDN to dc=company,dc=net. This is because you are using the default container to hold your users instead of an organized OU structure. Ideally you should not keep your users in the default container. OU structure allows for better organization an the assignment of group policies. See the image below: