powered by Jive Software

Openfire and XMMP client (pidgin)

Hello,

i use openfire V 3.3.3 on debian Sarge

openldap V 2.2.13 for euthentication (on Debian Sarge)

and pidgin V 2.1.1 as a client for Jabber protocol.

My problem is :

Each user can’t see if the other are online because the status stay “Not allow”, even if all the users are connected to the server. is there something to do on the configuration file? do you know where the problem come from? is there a solution?

Have you tried using the Spark client to see if it is a setting on OpenFire or Pidgin?

i test my install with “Spark” client, each user can talk to each other.

When i add an user (on Spark and pidgin) it appear as “Pending” on the first and “Not Authorized” on the second!

i do a basic install of openfire (with LDAP authentication which works) …

Do you have groups setup in LDAP? Do you allow your users to see eachother in groups they do not belong to? You should not have to add any users to a roster that is generated by your LDAP groups. Try adding all your users to the same group and see if they populate your roster automatically. Also you will need to change that group’s setting to allow all users of that group to see eachother.

I have noticed that when trying to add a MSN user to my roster using the Gateway service that I have issues with them showing on my roster untill they authorize me with their MSN client.

I create a group in my LDAP server (corp), then i put all the users in this group (a posixGroup for information) with attribute memberUid and there is no difference.

How can i allow users to see eachother in groups they do not belong to? i don’t see an option for that!

But now, with this configuration, i still have the same problem. all my users is show as Pending on spark even if i can talk to them.

Have you installed and configured the subscription plugin to intercept and accept requests (see attached image)?

When you open the OpenFire Admin site and browse to the Users/Groups tab, you get your list of users, right?

Then when you click on “Group Summary” on the left navigation, you get a list of groups, right?

Click on any group that has members in it and you will see a list of options along with the user list for that group. Make sure “Enable Contact List Group Sharing” is Enabled. If you want that group to bee seen by members of other groups, then click the “Share group with additional users” check box. This will let you share the group will all your users or just selected groups.

Thanks for your help (the path to allow user to talk each other). I select my group which has all my users. The option « Enable contact list group sharing » is selected.

I tried to « Share group with additional users » and selected « All user » but when i click on « Save contact … » button, the openFire Adim web site said: « Enter contact list group name ». An idea?

I don’t know if my last modification (with "subscription plugin) does the job. But now, I can see all my contacts’s status on the both client pidgin and spark.