powered by Jive Software

Openfire and XMPP

Hi,

We used to use Wildfire with PSi, but the server was unable to deal with the strain, so I was forced to upgrade to Openfire when transferring servers, however after installing this I couldn’t get PSi to connect, I have also tried a lot of other XMPP IM clients, when I use Spark it connects fine, the only problem with Spark is how resource heavy it is, and some of the computers we use here just aren’t up to the job, as well as one of our offsite locations drops its connection quite frequently.

The problem with the XMPP clients seems to be the same issue, which is “Not Authorized”, I have googled and searched support forums, but cannot seem to find a solution, the usernames and passwords are correct. Most of the settings are default however I have got the IM Gateway plugin installed and enabled. Any help would be much appreciated.

P.S I am very new to this as I did not do the previous install.

Thanks in advance,

Danny

anyone??? Could really use some help with this please…

BUMP!

probably has to do with the encryption type. not sure how to change those settings in other clients.

Additionally I just tried the latest version of psi with the latest version of openfire and it connects fine after you trust the self signed certs.

Firstly, thank you for the reply!

Secondly, I have enabled “Ignore SSL Warnings” in PSi, is this what you meant by allowing self cert? I have tried this and still no luck, I really don’t understand why it won’t work…

no psi asked me if I wanted to trust the openfire certs

do not disable the warnings. you may need them to get the certs accepted.

Thanks again for the reply.

Here’s what happened when I took off the SSL Ignore option and tried again.

http://i662.photobucket.com/albums/uu344/vrsdanny/ssl1.jpg

This came up, so I clicked “Details”…then I got this screen which I can’t see any other options.

http://i662.photobucket.com/albums/uu344/vrsdanny/ssl2.jpg

So I closed that and clicked “Continue” and got the same error as I normally get.

http://i662.photobucket.com/albums/uu344/vrsdanny/ssl3.jpg

I still dont get where Im going wrong, I know its got to be somthing logical, which drives me even more insane…

did you give your openfire server a FQDN like chaterver.domain.com or chatserver.domain.info? the cert seems to fail because it is invalid.

I wasn’t aware I had to give it a FQDN - showing how much of a newbie now. Thanks for the help. I will try reinstalling with a FQDN and let you know

Would just like to say a big thanks to Todd Getz, this has resolved my issue.