Openfire client can not get any message


Today I put the openfire server from 3.9.3 upgrade to 4.0.2,then the client will can not receive any message,I checked the database to find information is stored in the offline data table, and need to log in again to receive the message.I also reviewed the background log and didn’t get any errors.

What kind of changes is the server after the upgrade done? Who can help me,please?

What Java version is showing on the first page of Admin Console? You have to use Java 8 with Openfire 4.0.2. Also, what Os is Openfire installed on? What client do you use and what version?


Thanks for your answer.I have solved this problem.I put the user priority set to -1 when the user successfully landed.However, priority is intended to bear a special.After openfire 4.0.2 version, user can not receive a negative net jid information when priority is bear, so I put the user’s priority has become the default value of 0, then the problem is solved.

Finally,thanks for your answer again,because your answer might provide a solution ideas for other users with the same problem with me.