powered by Jive Software

Openfire Connection Issue to client connection


Openfire 4.0.1 install on my pc ip it work fine and connect successfully.
But Problem is below

I point my pc ip global like ip point to so connection on connection not work but connection work fine.

Can You please tell me can change any configuartion…?

port 5222 is enable

You should use domain names instead of IP addresses. I guess your domain name is and when you enter IP address when connecting from outside it thinks that your domain name is In that case i would suggest reinstalling Openfire and specify some domain name for it instead of IP. You also haven’t mentioned what you are using to connect. If you use Spark and if your domain name is not in DNS, you can still use domain name on the login screen, but on the Advanced settings page specify external IP in the host field.

Thanks wroot, Android App connection with ( openfire server.
Now, I got following error during authentication of xmpp connection with openfire.
My openfire version not showing SASL authentication . It completely working on my local machine.

xmpp connected is work but authentication not work.

It works on your local machine as you use same IP address as one that it is set as a name of your xmpp domain. Anyway, if you won’t start using domain names you will run into many different issues…

Thanks wroot,

Problem is solved:

uset_id@ jid is use during authentication is correct
but app user use following jid with new ip
uset_id@ jid is use during authentication is wrong.

In my openfire database have below jid uset_id@

In Short to use JID concate with old ip not new ip (@ it’s use for only host configuration others settings as usual.

I’d like to stress @wroot’s point: you should not use IP addresses for the XMPP domain name. Use a domain name instead, and have DNS A/AAAA records point to the correct IP address. For more complex scenarios, DNS SRV records can be used.