powered by Jive Software

Openfire connection issue when more than 1500 user try to connect

Hiii i developed one chatting application using openfire. Chatting working fine but suddenly openfire stop working means when cross 1500 active session openfire disconnected automatically from all devices. i again try to connection but getting exception.

what version are you using and what os?

I am using Openfire 4.1.4 and ubuntu linux OS

Hii Speedy

I am getting this exception when try to connect with openfire
CONNECT SMACK EXCEPTION:No response received within reply timeout. Timeout was 30000ms (~30s). Used filter: No filter used or filter was ‘null’.

sometimes openfire connected and user authenticated after suddenly after sometime connection automatically close. this is only happened when more than 60 user active per minutes. please check screenshot where user status showing authenticated but their presence in offline means they are unable to chat.

you might be hitting the max number of file descriptors in ubuntu. I think ive seen this posted before, but I don’t have alot of experience with Ubuntu to be any real use.


Hii speedy

Thanks for good suggestion but unfortunately i am unable to success

according to above link i changed ulimit -n (open file) value from 1024 to 4096 but after reboot server again getting same old value 1024. i am not understand whats going wrong with server.

step 1:
$ ulimit -n
1024

step 2:
$ ulimit -n 4096

step 3:
$ ulimit -n
4096

step 4:
$ reboot

step 5:
$ ulimit -n
1024

Are you editing /etc/security/limits.conf ?

yes i edit limits.conf file

vi /etc/security/limits.conf

  • soft nofile 40000
  • hard nofile 40000

but still getting ulimit -n value 1024

The steps you showed in the previous message did not state anything about editing this file. Did you reboot after editing the limits.conf file?

Are there any errors being logged in Openfire?

so how i edit /etc/security/limits.conf file?
yes i reboot after edit limit.conf

here the exception when try to connect with openfire
No response received within reply timeout. Timeout was 30000ms (~30s). Used filter: No filter used or filter was ‘null’.

I changed following configuration but still facing connection issue :frowning2:

please tune following parameters :
Increase openfile limit
Increase tcp connections limit
Increase max user processes