powered by Jive Software

Openfire Connection time taking long

I was using openfire v4.2.3 earlier and recently switched to v4.4.1 in the month of October.

We are having a traffic of approx 10-15k users concurrently .

When using v4.2.3 , our max traffic went upto 50k users and there was no problem in connection and the stanzas were getting exchanged timely.

Post using v4.4.1, there are a few observations :

  1. After a certain point of time, the XMPP socket connection becomes slow

  2. Packet exchange speed reduces

This happens after a period of time. (approx 48 hours).

Could you help me solve this issue?

Also, would be grateful to know if there is some monitoring tool / technique where I could figure out the XMPP connection time / packet delivery time of my clients?

Quick reply on this would be appreciated.

Are you reproducing this issue with the most recent release of Openfire?

Facing this with Version 4.4.1

Pls upgrade your version up to 4.4.4

Hi ,
Was there any issue in version v4.4.1 for connections which got fixed in 4.4.4.
Can we get details about the issue in v4.4.1 . Please let us know what was the issue and got fixed in in 4.4.4.

@akrherz your inputs would be highly appreciable over here. I think @ankitt0808 has raised a valid point. If you can tell something over here, it would be of great help.

You are not correct. Step 1 to diagnosing if you have a valid bug with an open source project is to run the latest release.

@akrherz , @ilyaHlevnoy
Just to confirm, the latest version (4.4.4) is https://github.com/igniterealtime/Openfire/tree/v4.4.4?

Or if it present under any other branch / tag, so can you please mention it.
It ll be of great help !

Thanks in advance !

Installers are available here https://www.igniterealtime.org/downloads/
Unless you are building it from the source for some reason. Then your link should be right.

We have found the probable problem area , and tried fixing it.
It was around the use of JVM Cache.

Now our system is smooth. We are able to serve the traffic for 15k users with much ease.

Thanks @akrherz @ankitt0808 @ilyaHlevnoy @wroot

That’s great, but please share the details of what you did to the JVM Cache settings so that others can benefit.