powered by Jive Software

Openfire Dialback MUC

Hello,
We are working on implementing dialback and having it function with openfire. While testing we are able to get one to one communications working between openfire and our server we have not been able to get MUC to work. Actually on the presence packet sent to the openfire server (from ours) the chat room lists (via the admin console) that the user is there but fails to respond. A different user connected directly to openfire and in the chatroom can no longer send messages at this time either.

I have looked at the logs, and it negotiates dialback successfully and there are no errors reported (in either the error log or the debug log). As such I am not sure where to go with this. Any help would be greatly appreciated.
-Trevor Adams

We federate more than 10 servers and in 99% of the cases its a DNS problem:

First add the SRV records _xmpp-server and _xmpp-client. Try if it works when you add conference.onedomain.com and conference.theotherdomain.com to your and the other DNS server (or /etc/hosts file or \WINDOWS\system32\drivers\etc\host).

I had DNS issues in the beginning but I think I have a working configuration at the moment. I have the onedomain and conference.onedomain (and otherdomain and conference.otherdomain) in the /etc/hosts file on both machines. I can do one to one chatting, if I tried to send a message packet to a room instead of the presence I get a “not acceptable” error message which is reasonable as I haven’t joined the muc yet. When I try joining the muc the openfire server gets the presence packet and never says anything in response (also all joined users to that muc can no longer say anything).

Thanks

Can post what you see in the log? You may also enable Message Audit Policy to see the message exchange.

Have you tried to initiate the conversation from both ends? sometimes we have seen it working one way.

How did you configure your server (just with domain.com or hostname.domain.com)?

Does you client use exactly the same?

Do you use a DNS server at all? Have you entered the SRV record?

Have you tried whether reverse nslookup works?

So, this is going to sound weird. It works now. I think what may have happened is that openfire was put into a non-operating state (if it tries to multiplex with another server and the other server does not respond weird stuff happens) I restarted to take the logs and viola. Thanks Micheal for all your help.