Openfire, fastpath, webchat - disable transcript in database


I have recently setup openfire with fastpath and i can’t seem to figure out how to disable the chat transactions being logged into the database.

I have read through most of the posts here, message audit is definitely disabled (which appears to be a filesystem log anyway)

monitoring plugin is NOT installed

and finally i also ensured the default settings for group chat conference rooms do not log chats. (it appears as if fastpath essentially creates a group conference on the fly and throws the users in there).

I feel like the latter is the closet thing to the actual problem but i am still getting transcripts in the database which i need to turn off.

Does anyone know what i might be able to do here?

Any help appreciated.


I have looked thourgh the settings and i can’t find anything, so probably it was ment this way. Fastpath is saving the conversations to be able to send chat transcripts to the person who was asking for support. You will have to modify Fastpath sources and build your own version to make it stop doing this. Also you will have to customize the form presented to a person, so it won’t advertise that option (getting the transcripts). Can’t say which parts of the code should be modified.

Hmm that is a pain.

I have already removed the email transcripts from the webchat plugin that was straight forward enough.

Does anyone know where i can get the source to the fastpath plugin?

Thanks for your help.

Looks like you were definitely correct

in there is an explcit call to updateTranscript that persists it to the database and isnt wrapped in any logic to do otherwise, commenting this out should do the trick.

Hope this answers the question for anyone else out there.