powered by Jive Software

Openfire Federation

Hi,

I’ve troubles with Openfire Federation.

The configuration is correct and DNS too.

What’s the trouble?

Do it need other port diferent to 5269 ?

Thanks.

Hi David,

do you see errors in the log files?

LG

Hi LG,

In the attached log file are the errors and warnnings.

If Openfire versions in the servers are differents, is there some trouble ?

Thanks.
logs.rtf (9959 Bytes)

Hi David,

which Openfire version are you using?

You may want to updgrade or downgrade the search plugin to get rid of the " 2008.09.20 20:51:29 Plugin /opt/openfire/plugins/search could not be loaded: no plugin.xml file found \line" messages. Or did you install the plugin completely?

Then you have a problem with your vCards, as "at java.util.regex.Matcher.quoteReplacement(Unknown Source) \line at org.jivesoftware.openfire.ldap.LdapVCardProvider$VCard.treeWalk(LdapVCardProvid er.java:517) " indicates.

And there’s the " java.net.UnknownHostException: suranet.com " which may explain why s2s does not work. It may help if you would post your xmpp.domain and the one you want to connect to.

LG

Hi LG,

I’m using the 3.5.0 version in Windows and 3.6.2 version in Linux. The log files were cpatured in 3.6.2 version.

I did post xmpp.domain correctly, but don´t work yet.

Attached new log files.

Thanks.
logs2.doc (27136 Bytes)

Hi David,

which are the xmpp.domains you are using? Are “chatasesores.suramericana.com.co” and “suranet.com” the right ones?

Is “javax.net.ssl.SSLException: Unsupported record version” or “java.net.UnknownHostException: suranet.com” the exception which causes problems for you?

LG

Hi LG,

The xmpp.domains are spkinversura.suranet.com and chatasesores.suramericana.com.co.

Between both servers, the users can’t add them.

Regards.

David.