powered by Jive Software

Openfire hang/spark won't authenticate

Recently, I upgraded to 3.7.1, but I am not sure if that is related to the issue at hand.

Over the past few days, Openfire becomes unresponsive to new connections. Users that are currently logged in can send/receive chats and the roster is visable, but logged off users who try to login receive a “failure to authenitcate” message in windows. Adium seems to hang on “receiving data”. The admin console doesn’t load at all either (so I can’t login and check Java memory stats on logs through the GUI).

Restarting the process doesn’t solve the issue; I have to reboot the server. Once the server comes back online everything is a-OK.

I am running Ubuntu 10.04 and am using a mySQL database. Anyone else experiencing similar behaviour or have any clues as to what could be wrong?

Logged into the console today and noticed that Java memory usage was really high. I did some research of Java high memory usage and some other people had reported similar symptoms (clients are logged off automatically vs my clients that couldnt log on).

So, I modified the /opt/openfire/bin/openfire file and modified this line:

INSTALL4J_ADD_VM_PARAMS="-Xms128m -Xmx128m"

to this:

INSTALL4J_ADD_VM_PARAMS="-Xms256m -Xmx256m"

/crosses fingers**
**

Try editing /etc/sysconfig/openfire

Set this to the path where openfire lives.

If this is not set the script will look for /usr/local/openfire, then

/opt/openfire.

#OPENFIRE_HOME=""

If there is a different user you would like to run openfire as,

change the following line.

#OPENFIRE_USER=“daemon”

If you wish to change the location of the openfire pid file,

change the following line.

#OPENFIRE_PIDFILE="/var/run/openfire.pid"

If you wish to explictly specific the location of the log directory,

you can set it here. Note that this applies to the logs generated outside

openfire itself. If you want to change the location of openfire’s own

logs, see the system property ‘log.directory’. If this is not set,

it will default to $OPENFIRE_HOME/logs.

#OPENFIRE_LOGDIR="/some/where/logs"

# If you wish to set any specific options to pass to the JVM, you can

# set them with the following variable.

OPENFIRE_OPTS="-Xms256m -Xmx512m"

If you wish to override the auto-detected JAVA_HOME variable, uncomment

and change the following line.

#JAVA_HOME=/usr/java/default

ps -ef | grep openfire

daemon 13763 1 13 19:07 ? 00:00:06 /opt/openfire/jre/bin/java **-server -Xms256m -Xmx512m **-DopenfireHome=/opt/openfire -Dopenfire.lib.dir=/opt/openfire/lib -classpath /opt/openfire/lib/startup.jar -jar /opt/openfire/lib/startup.jar

Hope this help.