Openfire is not Working After upgrade to 3.10.0

Hi Everyone,

My openfire is not working at all.

When I login from spark after upgrading openfire to 3.10.0.

It gives me error invalid username and password.

I will really appreciate your help!!!

Update to Spark 2.7.0 Ignite Realtime: Downloads

Hi wroot,

Thanks for reply,

I done with updating spark, but still the same error.

Thanks again

Try uninstalling Spark and then installing 2.7.0 again. Maybe your installation hasn’t been updated correctly.

I uninstall and installed spark.

In Advanced, it still shows 2.6.3.

But in program and features in Uninstall, it shows 2.7.0

This is the error i am getting.

I had the same issue this morning. I found that if I went into the admin console, and changed the users password - then logged them in with the new password, the system worked.

I also had to install the new spark client 2.7 - The number you see in the admin console is whatever the resource is in the client (if I remember correctly).

Mine was originally 2.6.3. After I changed it in the advanced tab on the client - it was 2.7 (as that is what I put in the client).

Hope that helps.

Go to Admin Console (Openfire) and set it like that:

In Spark > Advanced, make sure you DON’T have “Use old SSL port method” enabled. The 2.6.3 number in the Resource field is not important. It is not a version of Spark you are using. Spark sets this field to the current version of Spark when you first run it with a new user and it stays like that, unless you change it. You can change it to say “work”, or just “spark”, so it won’t confuse you in the future.

Well, you can try changing the password, though i’m not sure how this can be a cause. You can also go back to Openfire 3.9.3 if nothing works and wait for newer version, which maybe, maybe, will have a fix for login issues.

Thank you so much for your help.

But it didn’t work for me. I took your advice and switch back to 3.9.3 and it start working for me.

I also have one more issue. can you please take a look into that too?

User and Group Issue with Active Directory on Openfire


thanks for your help.

I switched back to 3.9.3 and it start working.

I have another issue, if you can help please.

User and Group Issue with Active Directory on Openfire


I’m not using AD integration myself, can’t help with that.