powered by Jive Software

OpenFire Jappix plugin behind NAT (AWS Elastic IP) - Help

Hi have set up OpenFire with the Jappix plugin on an AWS EC2 instance within a VPC.

I can bring up the Jappix client successfully from within the AWS subnet i.e. using http://private-AWS-IP:7070/Jappix but I cannot reach the Jappix client from outside (i.e. the internet) using the Elastic IP address (essentially a NAT’ed situation) i.e. http://public-ElasticIP:7070/Jappix leaves the browser just waiting until it times out.

I can however connect to the OpenFire server from outside i.e. using the public-ElasticIP and Spark on port 5222.

I have checked and double checked both the AWS security groups, the ACLs, the Windows firewalls (on the server) and ensured that port 7070 is open to the internet. I even tried momentarily opening every port and could connect to port 9090, bringing up the Admin interface, but still no joy on 7070 with Jappix plugin.

I have spent the past 3 days trying to make this work and am at the point of setting fire to something

Please help someone…

thanks

Warren

I believe the issue may extend beyond the Jappix pluggin.

Using http://private-AWS-IP:7070 I get the standard reply from the OpenFire HTTP bind service i.e.

Openfire HTTP Binding Service

Using http://public-ElasticIP:7070 however also leaves the browser just waiting until it times out.