powered by Jive Software

Openfire LDAP query problems

Openfire Server 4.0.4, Windows Server 2012 R2 :-

We are trying to set-up Openfire with Directory Server (LDAP) in Profile Settings,  but cannot get the LDAP query in User Mapping to work.

 User Mapping ->Test Settings fail “…..No users were found using the specified configurations …..”

If we ignore the failure and continue, Group Settings->Test Settings fail with a similar message.

If we ignore this failure and continue, then it’s not possible to set-up an administrator account …No username was provided or the specified username was not found…….

If we enable LDAP Interface logging on the Domain Controller event viewer, then this confirms that an LDAP query is received from the Openfire Server,

and an error is returned of type 0000202B: Referr DSID-0310082F

Note if we invoke ldp on the Domain Controller and search for users on the same domain path with subtree selected, then the users are found OK

Detailed Openfire set-up :-

Database settings->Embedded Database

Profile settings->Directory Server (LDAP)

Profile Settings Connection Settings :-

Server Type->Active Directory


Base DN: dc=NAME1;dc=NAME2;dc=NAME3;dc=NAME4

Administrator DN: openfireadmin@NAME1.NAME2.NAME3.NAME4

Password: *******

Test Settings passes OK

Profile Settings User Mappings always returns no users on Test Settings.

We’ve tried various combinations but with the same result.

The Default :- Username field sAMAccountName ; Search Fields blank ; User Filter : (objectClass=organizationalPerson)

We’ve also tried User Filter : (displayName=*) and also (displayName=openfireadmin).

On User Profiles, we’ve tried the default settings, we’ve tried removing all the fields, and we’ve tried removing all the fields except the ones for which there are definitions at the Domain Controller.

There is a single domain NAME1.NAME2.NAME3.NAME4. For a start, just to make sure we how to drive the set-up, the openfireadmin user is located in the default users folder.

We are somewhat newbies at trying to set-up Openfire, any help would be appreciated.

We have sorted the problem out ourselves. Real newbie error I’m afraid, we had the base DN fields separated by semi-colons, rather than commas.