powered by Jive Software

Openfire Meetings - Update


#1

Chrome version 57 makes a breaking change to webrtc that breaks Openfire Meetings. For details, read this.

You can apply a work-around by using the meetings settings admin web page to force a “negotiate” rtcpMuxPolicy as shown in the screen shot below.

ofmeet.jpg

Otherwise, upgrade to version 0.3.29 from github here.

The 0.4.x branch is now up-to-date with the latest Jitsi code including the mobile Jitsi-Meet applications for iPhone and Android. It can be previewed from here. It is still work in progress. If you test it with the mobile app, enter the full URL of your Jitsi-Meet application (https://:7443/ofmeet/jitsi-meet/) and ensure your Openfire allows anonymous xmpp connections.


#2

Hi Dele,

I’m continuosly testing ofmeeting since the very first release and it’s a real interesting plugin. Unfortunately I’ve a issue that I could never resolve since the beginning: OFMeet works only using internal clients not external -> ICE Fails even if i specify the proper values on the field such as:

{‘iceServers’:[{‘url’:‘stun:stun.l.google.com:19302’}]}

The machine work has also as a jinglenodes plugins and rayo whose internal tests returns an “ok”.

Reading the logs seems that for the external client (that access to the site from it’s external access) is not able to have it’s public address correctly translated.

Could you help me?
I’ve another issue with the spark meet plugin but I’ll try it after resolving this issue if possible.

Thanks for the help you could give me.

Regards

Giorgio


#3

To use it with external clients, you have to specify the correct external IP address and internal IP address in the settings web page. By default, they are both set to the same value which is the first IP address of the local Openfire server. This value works most of the time with a single IP address server on a local network. In reality, it will fail with multiple IP addresses and external clients if there is NAT between server and external clients


#4

Hi Dele,

in effect the openfire server has only one single public ip address to avoid nat and such other things (and work as a REAL bridge).

It seems all ok but the result (seen on the logs) is that the external client will not present itself with the public ip instead of the private before nat, so ICE fails.

Do you have any clue on what I culd check?

Regards


#5

This is now straying outside my area of expertise and knowledge.

If your client is behind a NAT and your OF is also behind a NAT, then that sounds like a bad scenario to deal with. A TURN server might be needed.

If your client is behind a NAT, but your server is on the Internet like mine, that should work fine with a singe public IP address.

The use case I was referencing is when your OF server is public, but still behind a NAT router. For that, Jitsi-videobridge needs to know both the local and public IP address of the OF server in which it is running…


#6

Hi Dele, the server has only 1 single public IP address just to avoid further complications but, in any case, the meeting between an external client (behind nat)and an internal client or 2 external client (behind nat) won’t work at all even specifying turn server.

If it can help I can tell you that the old Jappix web app, in the same situations described above works specifying the google stun server.

Regards


#7

Hi Dele,

today we got this problem on several PCs which automatically updated the Chrome Browser.

I tried the settings, but was not able to save it. The string was always damaged and not compledly saved.

Then I tried the update to 0.3.29 which also did not helped, we can’t use the Meetings anymore.

Any suggestions what I can do to solve the problem?

Our server is updated to 4.1.3.

Best regards,
Dirk


#8

after updating to 0.3.29 (and restarting openfire) I cannot access the Openfire Meetings web gui.

I have tried

https://myserver:7443/ofmeet/jitsi-meet

https://myserver:7443/jitsi/apps/ofmeet

https://myserver:7443/ofmeet

All i get is This site can’t be reached


#9

Trying to install openfire Meetings and Openfire Focus Provider on openfire 4.1.5 get unzip error

2017.07.21 18:29:25 org.jivesoftware.openfire.container.PluginMonitor - An exception occurred while trying to extract plugin ‘ofmeet’:

java.util.zip.ZipException: error in opening zip file

at java.util.zip.ZipFile.open(Native Method)

at java.util.zip.ZipFile.(ZipFile.java:219)

at java.util.zip.ZipFile.(ZipFile.java:149)

at java.util.jar.JarFile.(JarFile.java:166)

at java.util.jar.JarFile.(JarFile.java:130)

at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask.unzipPlugin(Plugi nMonitor.java:347)

at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask.run(PluginMonitor .java:184)

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301 (ScheduledThreadPoolExecutor.java:180)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Schedu ledThreadPoolExecutor.java:294)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

at java.lang.Thread.run(Thread.java:748)

2017.07.21 18:29:25 org.jivesoftware.openfire.container.PluginMonitor - An exception occurred while trying to extract plugin ‘offocus’:

java.util.zip.ZipException: error in opening zip file

at java.util.zip.ZipFile.open(Native Method)

at java.util.zip.ZipFile.(ZipFile.java:219)

at java.util.zip.ZipFile.(ZipFile.java:149)

at java.util.jar.JarFile.(JarFile.java:166)

at java.util.jar.JarFile.(JarFile.java:130)

at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask.unzipPlugin(Plugi nMonitor.java:347)

at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask.run(PluginMonitor .java:184)

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)

at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301 (ScheduledThreadPoolExecutor.java:180)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Schedu ledThreadPoolExecutor.java:294)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

at java.lang.Thread.run(Thread.java:748)


#10

after a java update it is now working


#11

I just used the default, seems to be working


#12

I have been unable to get jitsi meet to join a room (android), “Openfire allows anonymous xmpp connections” where is that option?

UPDATE another issue - When more then 2 people join Openfire Meetings breaks (no audio or video).