Openfire MUC supress join/left notices?


current version openfire 3.9.3, created a MUC in conference.domain.tld, put some people in.

users use mobile jabber clients and we dont talk much so the chat is full of “has joined” and “has left” notices. (actual notice may differ, server/clients are german)

its hard to find actual messages of the users

is there a way for the server (openfire) to supress those messages? if so, how?


You want to suppress those messages on the client side not service side

if it was that easy. it is not.

I want to know if I can surpress the messages on the server side and if so, how.

To reiterate what Flow has said. Server is only sending a presence update to a room when someone is joining or leaving the room. It must send a presence update, otherwise client won’t know who is online or offline in that room. Clients decide on their own whether their want to accompany presence changes with some additional messages. Server can’t force clients to stop doing this as there is no special command for this. This is a GUI part of a client. Some clients has an option to turn such messages off, some don’t.

if it was that easy. it is not.
Why is not easy? Should be simple to add such an option to any open source client.

You can’t block those on the server, otherwise the clients wont know who is in the room.

Well if his users use various clients and not only open source and if they don’t have a programmer or can’t pay one, then i see that this can be tricky.

thanks for giving me the answer “does not work on server side”

and for explaining why.

indeed, the problem is that I dont have control over the clients people chose to use. I control the server.

and although open source is awesome and in theory can be changed and adapted to the needs…

suffice it to say I dont have the ressources.

I’ll give the users a short list of clients which support disabling those messages.

You can suppress the message on the server side, but then clients do not know who is in the room. On the Admin Console, check out the ‘Broadcast Presence’ checkboxes for the room configuration.