powered by Jive Software

Openfire nao conecta externo

Boa tarde a todos, tenho uma estrutura do seguinte modo: 1 roteador sem fio tplink tl-wr941n e 1 Broad Balance tplink r470T, instalei o penserve em uma maquina, criei os grupos, etc, instalei o spark e internamente tudo beleza, instalei o spark em uma rede externa e nao consigo conectar, ja redirecionei as porta para o ip do servidor que e 10.0.1.121, tenho ip fixo, mas infelizmente nao consigo conectar externo, ja tentei de tudo, se alguem puder me ajudar agradeco.

Obrigado

Olá amigo, vamos por partes:

Como é sua rede interna:

Servidor openfire - Switch - Firewall - Router/Modem - Internet ?

Antes de nada, acessa o site:

http://meuip.datahouse.com.br/conteudo-ferramentas.asp

Vai na opção para testar se as portas estão liberadas, depois vamos testando externamente.

Obrigado do retorno Vinicius, minha rede tem ip fixo em um modem fibra vivo modelo echolife hg850a, que por sua vez esta ligado em um roteador tplink tl-wr941n, que por sua vez esta ligado em um broadbalance tplink tl470t pois ira colocar outra banda de internet mas sendo da net, inernet de 10 mb, as portas conforme os testes estao fechadas, embora fiz alguns procedimentos para liberar ou redirecionar para o ip interno do servidor openfire, mas nao funcionou. Interno funciona direitinho, ja montei o servidor, coloquei o spark, mas externo nao rola, estou acessando minha maquina de casa com um usuario daqui, mas nao rola…rsss

Olá amigo, então, precisamos primeiro liberar as portas para fazer o acesso externo pelo seu ip externo, como você tem varios aparelhos interligados, vamos precisar fazer direcionamentos abrindo as portas para conexão externa e direcionando ao ip interno do teu servidor openfire.

Qual é o equipamento do seu link de internet, nele que vamos liberar as portas, nos outros, vamos ver depois, pode ser que tenha que fazer o direcionamento de um para o outro, criar dmz, etc, vamos indo por partes até ajustar. Sabe liberar portas no modelo do router do seu link?

Pelo que vi aqui quem esta cordenando todos e o broadbalance tplink tl-r470t, tem opcao aqui, virtual server, port triggering e alg, o range de ip do servidor e diferente do tplink roteador sem fio o , acho que a configuracao em vez de ser feita neste broadbalance pode ser feita no tlr470, pois tentei no broad e ele chia por causa do range do ip

Amigo, vamos fazer o seguinte, coloca como é sua estrutura pelos equipamentos e seus respectivos modelos até o servidor openfire:

1-Link internet (router/modem modelo X)

2-Equipamento para balanceamento de likn (router modelo X)

3-Equipamento router wi-fi (modelo X)

4-Switch (modelo X)

5-Servidor openfire

Assim, vamos acessando todos os equipamentos em ordem, procurando pelas configurações de NAT, onde direcionamentos as portas do openfire para responder em algum ip interno, exemplo:

ip valido internet exemplo 200.200.200.200 - Router habilitando NAT nas portas 5222,5223, etc. direcionando para um ip interno 192.168.254.254 , este ip interno pode ser direto o servidor do openfire, ou até mesmo seus equipamentos para balanço, e neles basta criar outra nat até o ip real do servidor openfire.

1-Link internet (router/modem modelo X) - MODEM VIRTUA VIVO HG850A

2-Equipamento para balanceamento de likn (router modelo X) TPLINK TLR470T - CLIENTE DO SEM FIO

3-Equipamento router wi-fi (modelo X) TPLINK TL WR941N- FAIXA DE IP DE REDE 10.xxx.xxx

4-Switch (modelo X) 3COMM- 3CBLSF26

5-Servidor openfire - 3.9.1 -IP INTERNO 10.0.1.121

Boa tarde, vinicius,mudei tudo aqui, o openfire roda direitinho interno, agora externa nem pensar, ja fiz a liberacao das portas 5222,5223,7777, mas de foa realmente nao acesso, estou com uma maquina remota tentado acessar de fora mas a mensagem que da e que nao achou o servidor, tenho ip fixo, mas nao tem como.

Atualmente a configuracao dos equipamentos esta assim

MODEM FIBRA IP FIXO

TPLINK TLWR941N - IP: 192.168.0.2

TPLINK TL R470T > IP: 192.168.0.1- GATEWAY

SERVER DHCP TPLINK WR941; FAIXA DE IP E CLINTES: 192.168.1.XXX

Amigo, você fez o teste no site do meuip, apareceu que as portas estão liberadas?

sim a porta unica esta fechada a porta d servi;o esta aberta

Amigo, então tenta fazer um telnet na porta de algum lugar para ver se responde, se ver comigo no skype (suporte.fugacouros), eu posso fazer os tester e ir lhe avisando se esta tendo conexão ou não.

No spark coloco o usuriario, senha e no servidor o ip fixo, mas nao vai.

Primeiro tem que testar se a porta esta respondendo no teu ip externo, pode fazer isso usando o telnet, ou o programa para procurar portas abertas, para você não expor seu ip, tenta fazer o procedimento pelas duas opções a seguir:

1-telnet (Abra o CMD da maquina, e digite: telnet, se o recurso estiver ativo, vai abrir a tela de console dele, e nela você faz assim):

open xxx.xxx.xxx.xxx pp

onde X=ip, P=porta

2-Software Free Port Scanner, usando algum computador fora de sua rede interna, digita o seu ip externo, coloca as portas que deseja checar e testa por ali.

Caso o recurso telnet não esteja ativo por padrão, pode ir no painel de controle, em programas e recursos, vai em ativar ou desativar recursos do windows, e la vai ter o recurso telnet para escolher.

Fiz o procedimento de um micro de fora e ele diz que nao consegui acesso ao host pela porta 23.

Dando um netstat -a e vendo as portas que estao abertas no servidor posso mudar, e colocar uma que esta listando?, fazendo esta alteracao de portas no servidor e no cliente?

Amigo, não entendi, você fez o teste nas portas 5222. 5223?

Essas portas que você deve liberar e fazer o procedimento.

telnet

open xxx.xxx.xxx.xxx 5222

open xxx.xxx.xxx.xxx 5223

usando netstat vai mostrar as liberações internamente, não externamente.

netstat usei no meu servidor open fire, interno, externo dei telnet 200.xxx.xxx.xx:5222

Ele deu erro, ou ficou tentando conectar?