powered by Jive Software

Openfire Not connecting within LAN but connecting outside LAN

Hi Everyone,

i made openfire server with pandion xampp client and open dyndns domain, through dyndns update software.also made port (5222) transfer configuration on router.

it’s working good from outside (WAN) which mean i create a user xxxxx@xxxxx.gotdns.com on openfire server and tested from outside LAN its working good.

but it’s not working from LAN. Anything need to be change in router?

Please need help to find problem.

Reman.

Maybe your internal DNS doesnt know this domain name. Try logging in using IP adress of the server or computer’s name.

Hi Reman,

can you resolve xxxxx.gotdns.com in your LAN? If it resolved fine then you likely have a routing/NAT issue with your xxxxx@xxxxx.gotdns.comrouter.

Anyhow it may be better to use an internal DNS server (or edit the hosts files of your clients) and make sure that xxxxx.gotdns.com resovles to your internal address (10.x / 192.168.x).

LG

Hi Wroot / LG, Thanks for u r reapply, as u said its working when i using openfire server name or IP in pandion connection settings. also need help that how to do domain resolve in LAN.

Thanks u both.

You will need to setup internal DNS and make internal clients use it as they default DNS server and then setup a hostname entry in this DNS with domain name and point it to an internal IP of your server. Or you can edit hosts files on all of your internal clients and bind this internal IP with domain name.

Hi wroot, once again thanks,

I am new in Serverside, it’s possible can u descibe step by step please. My internal domain name is (IND.HOME, my dyndns domain name is remanhome.gotdns.com) how to do it.

Thaanks.

Well, this is a bit too much to ask. We can’t do everything for you. If you use Windows Server as a domain controller or if you have another Windows Server, then you can install DNS role on it, then open DNS console and add A host “remanhome.gotdns.com” pointing to Openfire server’s IP. Of course you will have to make internal clients use this internal DNS. This is just to much to describe. Maybe you can ask someone to do it for you (system administrator).

Sorry wroot, thanks.

Hi Reman,

You may have sorted this out…but just incase. You can just create a static DNS entry on your router that points to that server. If i know what router you use, then maybe i can provide you with syntax/proceeds

Good luck