powered by Jive Software

Openfire on freebsd - weird problem start

On Freebsd

Installation of openfire-3.7.1_2.1 on freebsd 8.2 amd64

I am having trouble with openfire

Getting error

WARNING: no shebang line in COPYRIGHT

Here is the sequence:

service openfire start

Starting openfire

#service openfire status

openfire is running as pid 9205

#service openfire status

/usr/local/etc/rc.d/openfire: WARNING no shebang line in COPYRIGHT

openfire not running? (check /var/run/openfire.pid

Openfire definitely not running

Thanks in advance for any help

David

I finally fixed this by wiping the whole installation. It looks as though openfire somehow lost its configuration entirely and was unable to connect with the database. As I am setting up a new service in desperation I leted everything to do with openfire and reinstalled it. It is now working.

Maybe openfire needs a regular back up and reinstall all relevant files to previous state tool?

David

I’m seeing this too, looks like a corrupted procname check that results in:

  • _run_rc_doit 'openfire_stop ’

  • debug 'run_rc_command: doit: openfire_stop ’

  • eval 'openfire_stop ’

  • openfire_stop

  • check_pidfile /var/run/openfire.pid COPYRIGHT bin boot compat compat.old dev entropy etc home lib libexec limb0 media mnt proc rescue root sbin slim.core sys tmp usr var var.new

  • _pidfile=/var/run/openfire.pid

  • _procname=COPYRIGHT

And FreeBSD COPYRIGHT from / was selected as a pid file. The cause - openfire was not running. I’m reporting it to the port maintainer.