powered by Jive Software

Openfire server bug

guys i need help, i installed openfire today and the installation ended successfully. i run openfire and launched the admin console… configured it… and success! At this point, my server name is pschat-net, the problem is spark can’t find the server pschat-net. I tried to ping it and the result —> server unreachable.

BUT… if i use localhost as my server spark will connect to openfire. In the openfire window, it says there —>

Openfire 3.6.4 [May 28, 2009 9:46:25 PM]
Admin console listening at:
http://pschat-net:9090
https://pschat-net:9091

i have installed openfire 3.6.2 before up until now we’re still using it as our chat server and spark as the client application. I configured it and named it as philsundt-net. i did the same configuration of philsundt-net to pschat-net… Any ideas people?

Things i already did

Reinstalling

Reconfiguration: changed it to a different server name. none have worked.

Restart openfire several times

Openfire is not responsible for a ping, it’s the machine (and Operating System) where you have installed the Openfire should accept ping at send replies.

You have mentioned that with localhost you can login. Are you launching the Spark on the same machine you have installed Openfire on?

Is the old installation 3.6.2 on the same machine?

So far it’s hard to understand how your setup looks like and what you are trying to do.

i installed it on 2 different machine. Ok il make things clearly as possible. (“philsundt-net” is my old openfire server name installed in a different computer.) I requested a new computer and i want to install openfire newer version to the new PC because "philsundt-net is installed in a slow pc in our office. Well as planned, i installed openfire and spark on the new pc , configured it and fired. The problem is i can’t connect to my new openfire server using spark on the local machine and even on my other computers in the network. My new server name is “pschat-net”. <i hope it’s not confusing with the server names>., i disabled the “philsundt-net” (even it has nothing to do with the new server). no IP address conflicts because im using dhcp. Now i tried to ping “pschat-net” from my local machine where my newer version of openfire is installed. it says there “server unreachable”. while on the other hand, i also pinged “philsundt-net” using the old machine where it was installed and it gets a reply. So far my analysis here is openfire did not register the alias/hostname or domain for my ip address in my system. that is why when i use localhost for the server in spark i can connect…

thank you for sharing your ideas/solutions…

Reinstalling my operating system solved the problem.

tnx mate

Yeah, i would be blaming the operating system after i read you previous message Don’t forget to mark this thread as Answered.

Answered