powered by Jive Software

Openfire Server crashes with Openfire Meetings plugin

Hi together

I have an Openfire Server 4.2.3 running fine so far on an Arch Linux Server (with the Certificate Manger plugin installed). I now tried to install the “Openfire Meetings” plugin (Version 0.9.4). If I do so the Openfire Server crashes. Also a restart of the Openfire Server is ending in a crash. I need to delete the “Openfire Meetings” plugin to bring up the Openfire Server again.

OS: Linux Arch 64-Bit
Java: 1.8.0_181 Oracle Corporation – Java HotSpot™ 64-Bit Server VM

I could also provide the log files if someone is able interpret the information on it.

What could be the problem ? Some help is very welcome.

Linux system logs may have something about the crash too, but yes, any sort of logs would be helpful.

@akrherz : Thank you for your answer. Here are two log files, the “warn.log” file (error.log is empty) of the Openfire Server logging and an extract of system journal showing the crash (in the Java part, I believe… sorry but I’m not a Java programmer at all). I hope this helps to find the problem. If more information are required, please let me now.

warn.log (3,8 KB)
journal_extract.txt (20,3 KB)

Yikes, that’s not good that the JVM crashed. I am unsure what to suggest doing :frowning: Hopefully others can chime in.

Two things of note in those files;

2018.10.17 19:53:18 org.apache.commons.httpclient.HttpMethodBase - Going to buffer response body of large or unknown size. Using getResponseBodyAsStream instead is recommended.
It seems that something is misusing the the Apache HttpClient library, but I’m not sure what at this point. Possibly whatever is doing this is receiving a large body of text, causing a memory problem.

Oct 17 19:53:41 server.mydomain.com java[975]: # An error report file with more information is saved as:
Oct 17 19:53:41 server.mydomain.com java[975]: # /tmp/hs_err_pid975.log

It may be useful to post that file to gist.github.com if it’s still around/happens again.

Greg

ALSA lib confmisc.c:767:(parse_card) cannot find card ‘0’

Sound card may be missing on your server. See related issue

The crash happened outside the Java Virtual Machine in native code.

The crash is happening at O/S outside of Openfire. See related issue. Google about pulseaudio and installing dummy sound cards

@gdt that’s this issue https://issues.igniterealtime.org/browse/OF-1026

Ah , yes, that would be it. Probably worthwhile fixing in case a mistake replaces a favicon with an RPM file, or similar, but not exactly priority.

I already tried to solve the problem with installing ALSA and PulseAudio, but without success. The Openfire server still crashed. After that I removed ALSA and PulseAudio again from the server.

Do you know, is ALSA and PulseAudio required by the Openfire Meetings plugin ? My server is headless (like I believe most servers are) and no audio is required at all.

I also found this https://github.com/igniterealtime/Openfire-Meetings/issues/21 and if I interpret it correctly, audio support is not required.

Unfortunately a log file (like hs_err_pidxyz.log) seems not to exist. I could not found it on the server after reproducing the crash again.

In theory, yes. However the reality of using Jitsi Videobridge is the dependency on LibJitsi which does the media processing. See this related issue for more information

Ok, thank you… I will try it again to solve the problem… I give you some feedback if I could solve the problem with the installation of ALSA and PulseAudio.

DELE-Olajide, please contact me privately