Openfire-service fails on Windows Server 2003 R2/SP2

I have Openfire 3.5.2 running on Windows Server 2003 R2 w/ Service Pack 2. When I run it “interactively”, it runs fine with no errors whatsoever. But when I try to run it as service, it fails and and subsequent restarts fail with a somewhat ambiguous error message (as it appears in the eventviewer):

“The Openfire service terminated unexpectedly. It has done this 1 time(s)”.

There is no detail on the cause of the error. And Openfire’s own logs does not seem to report the error.

When I go back to running the service interactively, no problems. Any insight?


Openfire 3.5.2 / Connected to Active Directory for users/rosters

Postgres 8.1

Windows Server 2003 R2/SP2

Memory: 4GB

CPU: Intel Xeon 3GHz


Have you tried removing the service and readding it? Have you changed the java memory options?

I have tried to re-initiate/re-install the service multiple times, same result. Have not yet manipulated the Java memory. Naturally, I attempted the sevice install on a test box - it was successful (runs Win2k Workstation, 1GB RAM, 1GHz PIII, w/postgres and connected to the same AD). And I made no adjustment to the Java memory on my test box.

Still, I wonder why the my retries were not noted in the Openfire logs?


My openfire runs on that exact version of windows server. The hardware specs are not the same, but that should not matter. Are there any errors in the event viewer of the server when you try to create the service?

Nope. Just a singular entry per failure in the System log:“The Openfire service terminated unexpectedly. It has done this 1 time(s)”. The Security and Application logs do not reflect any difficulties.

I have attached screenshots of my service config. Also you may want to check the properties of the program C:\Program Files\Openfire\bin\openfire-service.exe, to make sure it is not blocked.