powered by Jive Software

Openfire service start issue

Hi,

I install openfire into my server(centOS) successfully. But, when I am starting opefire, it shows some error and FAILED status is shown.

[root@server ~]# service openfire status

openfire is running

[root@server ~]# service openfire start

Starting openfire (via systemctl): Job for openfire.service failed because the control process exited with error code. See “systemctl status openfire.service” and “journalctl -xe” for details. [FAILED].

Also it shows following things.

[root@server ~]# systemctl status openfire.service

  • openfire.service - SYSV: Openfire is an XMPP server, which is a server that facilitates XML based communication, such as chat.

Loaded: loaded (/etc/rc.d/init.d/openfire; bad; vendor preset: disabled)

Active: failed (Result: exit-code) since Sun 2017-08-06 06:59:28 UTC; 11min ago

Docs: man:systemd-sysv-generator(8)

Process: 4408 ExecStart=/etc/rc.d/init.d/openfire start (code=exited, status=1/FAILURE)

Aug 06 06:59:28 server systemd[1]: Starting SYSV: Openfire is an XMPP serve…

Aug 06 06:59:28 server openfire[4408]: Openfire is already running.

Aug 06 06:59:28 server systemd[1]: openfire.service: control process exited…=1

Aug 06 06:59:28 server systemd[1]: Failed to start SYSV: Openfire is an XMPP server, which is a ser…hat

Aug 06 06:59:28 server systemd[1]: Unit openfire.service entered failed state.

Aug 06 06:59:28 server systemd[1]: openfire.service failed.

Hint: Some lines were ellipsized, use -l to show in full.

[root@server ~]#

Please help me.

If it shows that it is already running, why do you try to start it? You can try the stop command first and then start.

Also, if it is running already, then go to Admin Console. On the same machine it will be http://localhost:9090.