Openfire setup error

My openfire drives me crazy…

Installed OF 3.7.0 on Ubuntu 10.10 After Installation I run the setup by http://localhost:9090 After laste step, ther was not the annonced admin-screen, but it started setup again … and again. I restarted openfire (/etc/init.d/openfire restart). But the Browser run setup again and again.

So I looked at /etc/openfire/openfire.xml - it was 0 Byte

here an excerpt of the error.log




2011.07.02 10:00:19 Error on line 1 of document : Premature end of file. Nested exception: Premature end of file. Error on line 1 of document : Premature end of file. Nested exception: Premature end of file.

at org.jivesoftware.util.XMLProperties.buildDoc(

at org.jivesoftware.util.XMLProperties.(




2011.07.02 10:00:19 Error reading XML properties

org.dom4j.DocumentException: Error on line 1 of document : Premature end of file. Nested exception: Premature end of file.



at org.jivesoftware.util.XMLProperties.buildDoc(

at org.jivesoftware.util.XMLProperties.(

at org.jivesoftware.util.XMLProperties.(




But before it was the same. Then I inserted some linesin openfire.xml like debug on And then I could get the admin-page in browser. Only got Problems with Spark, where loged-in users where shown as logged-out to other logged-in user ans vice versa.

Two years ago I got a openfire(3.4.x?) installed and running very well in Open Suse 10.x with Spark(2.5.x?) with red-5. I like it, and I want to use it with Asterisk as a all-in-one communication suite.

I am as user member of the group openfire.

How to get it running properly? Is it due to Java? Do I make a mistake with ‘user-access’

it is runnung in Ubuntu 10.10

here the directory entry of openfire.xml in /etc/openfire/

-rw-r----- 1 openfire openfire 0 2011-07-02 09:01 openfire.xml

I am as user member in the group openfire

This is the entry after endless tries of http://localhost:9090/setup


I added one line in openfire.xml:

debug on

and now opennfire is up and running. Cause openfire.xml is not empty any more. This is the only entry in openfire.xml. Setup did not write anything in it!! But it can’t be normal?

Why is /etc/openfire/openfire.xml not filled with data ??? And how to fix it ?

As Openfire reads the openfire.xml file it stores the settings into database, so it don’t need that file to be able to run. Also, check that your user, which is running Openfire, has write permissions to /conf or better to the whole /openfire dir and subdirs.

permissions are correct.

Openfire did run till yesterday. But it started to run when I added some stuff in openfire.xml !! Otherwise always setup and again and agein…

Today it came up with ‘setup’. As I finished setup it was always the same: openfire.xml 0 Byte and setup came in an endless loop.

Then I addes debug on Started setup in browser and then I got:

“The Openfire database schema does not appear to be installed. Follow the installation guide to fix this error.”

Unforturnetly ther is no help for it in the installlation guide.

Why will the setup start again and again? I even tried to restart openfire after setup. Did not help.

With openfire 3.7.0 and Spark 2.6.2 I always get troble. I de-installed it and re-installed it for almost 3 times. But after 1 to 3 days it crashes and nothing will help.

after the 5th (!!) try with restart, openfire is running. I don’t know why, but it is running.

Maybe its due to my hardware - I don’t know. I will install openfire on another machine tomorrow.

I will post my experiences with it :slight_smile:

I now deinstalled openfire full by dpkg -P…

Then I installed new. All data was lost (thats ok). And its unning.

I wanted to install plugins. But There are no available plugins any more. Update now’ results in ‘No new plugins available’

When I look in System-Properties I can see admin.authorizedJIDs with argument:


I can understand admin@linux-2, but what is apricot\ ??

I use a Redirection: ‘’. Is it due to the Hostname? How to built it ?

When you were doing web setup it asked about a hostname (server name). Maybe this is what you have left for the hostname. You should change it to something more usable.