powered by Jive Software

Openfire + Sip phone plugin, no registration attempts

Hi everyone! I have Openfire 4.1.3 succesfully installed and working and I am trying to make sip phone plugin work. I installed this plugin inside my server and I am now able too see it among installed plugins on Plugins page as well as new fields “Sip phone mappings”, “Sip settings” etc.

Then I created several sip phone mappings, where entered users(that really exist inside Openfire), their phone numbers from Asterisk, phone account logins and passwords, servers IP-address. When I press “Save settings” it saves, i can see it among phone bindings, but status is “unregistered”. If I try to press “Test” - I am waiting for results too much time and than see “Request timeout” error page in my browser. I’ve launched tcpdump both on openfire and asterisk server while waiting for “test” to response and did it several times, but there was no attempts from openfire server to register client on Asterisk.

I use Spark with Phone Client Plugin installed, but can’t even find “Call” button in it or something like this.

Am I missing something or missunderstood plugin’s behaviour?

spark sip has been broken for some time. you might give 2.7.7 a try, as it “kinda worked”

As far as the asterisk-im mapping. be sure you are using the correct plugin. it was broken for a while, and kinda worked after a new jar was complied. There has been some recent interest in asterisk and openfire. Hopefully dev will pick up soon, and some of the issue will get addressed.

As I’ve read somewhere on this forum, compatibility with Asterisk since Asterisk 11 was broken (and I have 13), so I didn’t try even install Asterisk-IM. If it is wrong, or is corrected now, I will be pleased to install it and make it work.

sorry…I misunderstood part of your post. the asterisk-im is not related to the sip plugin. Its mainly used for presence between asterisk and spark