powered by Jive Software

Openfire-Spark Avatar Error

So, I’ve been running Openfire 3.6.0 for a while now with Spark 2.5.8 on the clients. I’m using the default database, with LDAP integration. I’m trying to give my users the ability to update their profiles with avatars. I’ve looked at all of the tickets and nothing has fixed my problem. I tried the plugin, but then realized that it’s unnecessary for my version of Openfire. Right now i’ve got ldap.override.avatar set to true. I don’t have photos in Active Directory. When I try to add an avatar to my profile in Spark (Spark–>Edit My Profile…–>Avatar tab–>Browse…) it gives me the “Server does not support VCards. Unable to update your VCard” error. The below gets dumped to the error log.

Any ideas?



Dec 16, 2008 5:21:20 PM org.jivesoftware.spark.util.log.Log error
at org.jivesoftware.smackx.packet.VCard.save(VCard.java:495)
at org.jivesoftware.sparkimpl.profile.VCardEditor.saveVCard(VCardEditor.java:422)
at org.jivesoftware.sparkimpl.profile.VCardEditor.access$000(VCardEditor.java:50)
at org.jivesoftware.sparkimpl.profile.VCardEditor$1.propertyChange(VCardEditor.jav a:129)
at java.beans.PropertyChangeSupport.firePropertyChange(Unknown Source)
at java.beans.PropertyChangeSupport.firePropertyChange(Unknown Source)
at java.awt.Component.firePropertyChange(Unknown Source)
at javax.swing.JOptionPane.setValue(Unknown Source)
at javax.swing.plaf.basic.BasicOptionPaneUI$ButtonActionListener.actionPerformed(U nknown Source)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Openfire seems to be a bit picky with vcards and active directory… since it can’t write to AD.

Anyway, I get the same error in Spark AFTER I add my avatar, but it still works.

Check to see if you also have the System Properties ldap.vcard-mapping=“bla bla” and vcard.enabled=true, also provider.vcard.className=org.jivesoftware.openfire.ldap.LdapVCardProvider.

See attachment for suggested vcard mapping per Todd Getz (I use this also)

Got Luck! :slight_smile:
vcard_mapping.txt (850 Bytes)

Did you restart the server after enabling the avatar override.

Yay! It’s working!

I did not have the vcard.enabled=true set. Also for some reason my ldap.vcard-mapping string had this in it: “image/jpeg{displayName}”. Once I changed “displayName” to “jpegPhoto” and bounced the server, it started working.


Now I can get these users off my back. “When are we going to get avatars?” …bunch of whiners

What version of Openfire are you using? I can’t seem to locate the vcard option you are referring too, to set it to enable. I see the vcard.mapping option. Also, what formats are supported (jpg, mpeg, etc.)

Please advise.

Todd, since we’re running Openfire 3.6, is the change I need to make only the LDAP.Override.Avatar set from False to True? Also, this won’t try to write to AD correct?

Is Vcard the best way for Spark users to add to mask their IM information when using Fastpath?

I look forward to your reply.


No changes are made to AD. It is stored in the openfire database. Users cannot change their vCard info other than their avatar. Openfire is read only for vCard info when using LDAP.

Thanks for your reply. Is that the only option in System Properties that I need to change (ldap.override.avatar)?

I get this error as well when trying to upload an avatar via spark when its to big in size, some docs i found say:

“First, find a picture smaller than 16 kilobytes. You can check the size of the image you would like to use by right clicking on the image file and viewing its properties. Animated GIFs do not work with Spark.”

That looks to be old info now as its dated 2006, i know this is an old thread but i think my reply could be useful to others still because its the same error message and my first thought was somthing must be wrong with the server side.


1 Like

BEST advice for vcard errors - applicable even today (Jan 2013). I was racking my brain for hours trying to figure out why my users kept getting a vcard error. I thought it was a server side error and it turns out to be avitar file size too big (no point in using a photo larger than 150 pixels anyway because the avitar is so small). Told my users to use tiny images and now everyone is happy - including me!