Openfire sparkweb behind apache

I am currently running Openfire 3.4.2 on Linux (RHEL4). The server that Openfire is installed on has Apache running on port

80/443. So currently, I am using a proxy pass to get openfire

functionality (admin, webchat, sparkweb). I have tried several times to get sparkweb working, but to date I can not make it work.

Sparkweb login page gets shown, but then I get a message box

"Error: An unexpected problem occurred; The information following

this may be helpful for us in determining what whent wrong and fixing

it in a future version of sparkweb: Remote Server Error, 502" Then my browser goes back to the login page.

The only thing that shows up in the logs is:

2008.02.14 08:56:14 TLS was required by the server and connection was never secured. Closing connection : org.jivesoftware.openfire.nio.NIOConnection@209269 MINA Session: (SOCKET, R: /, L: /, S:

I get the above results both from using the proxy pass and when I go directly to port 9090 (

I have set “Server Connection Security” to optional, and then tried it with custom / TLS Method not available. I get the same message.

So my questions are:

  1. How to I get sparweb working (using port 9090)

  2. Is there a better way to configure apache/openfire (something like mod_JK) so that sparkweb will work properly through apache?

I believe the reason you’re receiving this error is because of the cause stated in your error log: “…Connection was never secured…” If I remeber correclty the sparkweb client will not connect securely unless the url used to load it was secure, for example “http://localhost:9090/plugins/enterprise/sparkweb/index.jsp” would not connect because the sparkweb client does not send a secure connection, where as “https://localhost:9091/plugins/enterprise/sparkweb/index.jsp” would, since the URL is using SSL.

As for apache I’m not sure how using it as a proxy would affect sparkweb, could you give me a more detailed example of the path a connection would take to get to your openfire server or sparkweb?

It is also possible to run sparkweb on a separate app server, so that you’d never actually have to open your admin port to the outside, you could just expose the app server.

I tried using the HTTPS url, but I get the same TLS error.

I set the Client security to be optional, and now I am not getting the Error. I found another thread that said something about this, and that encryption will be enabled in the next release of sparkweb.

As for sparkweb behind apache, the new sparkweb is not in a war file, so I was not sure how to deploy it to separate server. Based on I copied the /plugins/enterprise/web/sparkweb to an app server or web server. That did not provide a default page, so I copied the contents of the index.jsp from the default sparkweb into index.htm on this new web server and now sparkweb works on this server.

Is there a better way to install sparkweb remotely?

So I now have sparkweb “running” on an apache web server, but openfire is still behind apache using proxypass

for me I have found that when sparkweb is on apache, it doesn’t matter if its http or https it can’t connect if the server is requiring ssl. if I change security to optional then sparkweb can connect using http or https. I have another thread similar to this but am interested in finding an answer

This matter is more recently addressed here:

SparkWeb and TLS