powered by Jive Software

Openfire SSO Ubuntu guide

So, don’t know whats happening, in some windows 7 are working great, anothers not. In some Windows 10 is not working too. kkkk

very strange error.I would try to write on problem computers and look at which domain the controller is connected to and also check dns on the problem computer
nslookup srvchat.pmns.intranet

Screenshot_510

Here is mine.
image

Not getting the domain name.

I don’t know how to solve this problem, but maybe it will help?

Ok solved.
image

Now, how to deploy the config???

Does it work on all your computers now? Spark Config?

When i solved the nslookup problem, i think solved. So i need deploy to know if it will work.

on all computers I have a policy that adds a Reg entry.

and on all users I add a logon script(.bat).

I took my configuration file and added your server, but you can do it yourself.

IF EXIST "%AppData%\Spark\sso_enable2.8.3.txt" GOTO END

xcopy "\\srv-it\app\Spark2.8.3\spark.properties" "%AppData%\Spark\" /Y
copy /Y nul "%AppData%\Spark\sso_enable2.8.3.txt"

:END

spark.properties (1.7 КБ)

And here is the script how to install spark on all computers when they are turned on.(for 64bit system)

IF EXIST "C:\Program Files (x86)\Spark\spark_2_8.3.txt" GOTO END

taskkill /F /IM Spark.exe
"C:\Program Files (x86)\Spark\uninstall.exe" -q
rmdir "C:\Program Files (x86)\Spark" /s /q
mkdir c:\drv
xcopy "\\srv-it\app\Spark2.8.3\spark_2_8_3.exe" "C:\drv" /Y
start /wait c:\drv\spark_2_8_3.exe -q
copy /Y nul "C:\Program Files (x86)\Spark\spark_2_8.3.txt"

:END

and this script for 32bit system

IF EXIST "C:\Program Files\Spark\spark_2_8.3.txt" GOTO END

taskkill /F /IM Spark.exe
"C:\Program Files\Spark\uninstall.exe" -q
rmdir "C:\Program Files\Spark" /s /q
mkdir c:\drv
xcopy "\\srv-it\app\Spark2.8.3\spark_2_8_3.exe" "C:\drv" /Y
start /wait c:\drv\spark_2_8_3.exe -q
copy /Y nul "C:\Program Files\Spark\spark_2_8.3.txt"

:END

Ok, its one GPO each??

Ok i used ur spark.properties but when it will get the credentials from the username??
When i started spark my credentials was not there.

If you are an administrator on your computer, then Spark.exe needs to be run with elevated privileges (Run as Admin). If you have the rights of a regular user, then everything will work for you.
This is a longstanding issue of UAC and Java.


Or you can configure this setting on all computers through a GPO.

Ok, This config is just to run all aplications as elevated rights?

About installing programs it will not effect, right??

no, this does not allow the standard user to request administrative rights.

How to deploy this Runs As, cause i have 200 users, i dont want to go each user and make config.

I made this config, but need to run as administrator to get configs.

Are your users administrators on their computers?

No, its not.

I don’t remember whether a regular user needs to disable UAC …
In my opinion, the problem is only with administrators on computers, it should work for users and so, just add a Reg entry to all computers.


I did, but on users computers, still need to run as adminstratives, but the UAC not prompt. The user just need to right click, run as administrator, Yes. Then the app open and get the credentials.

Humm, i tried in Windows 10 computer, will try in windows 7 computer now.

After changing the UAC, you need to restart the users computers.

Dude, Thank you so much! All going well now.
I had tested on windows 10 with a user with Adm privilegies. Now its working good.