powered by Jive Software

Openfire stops responding once in a month

Hi ,

We are forced to reboot the server once in a while as suddenly openfire stops accepting client connections. We tried restarting openfire service but it did not work , Only works if we reboot the server all together , Any one knows the solution for this pls .

Thanks,

Venu

What version of:

  1. OS

  2. Openfire

  3. JRE/JDK

Hi David,

Thank you for response , Pls find the details below :

  1. OS

CentOS release 5.5

  1. Openfire

3.7.1

  1. JRE/JDK

jre-1.6.0-openjdk

Pls let me know incase you need any more details.

Thanks,

Venu

What is logged into nohup.out? Do you have xmpp.pep.enabled set to false?

Does the system have any useful information logged?

I had the same issue and increasing the Java memory fixed the issue for me.

Hi,

xmpp.pep.enabled was not set to false , i set it today .

Yes it is logging all the useful info.

Thanks,

Venu

Hi,

Were you referring to openfire.sh file ? I see only below files in bin dir

embedded-db.rc

embedded-db-viewer.sh

openfirectl

openfire.sh

Also i did not find the line **INSTALL4J_ADD_VM_PARAMS="-Xms256m -Xmx256m" in **openfire.sh

Pls help.

Thanks,

venu

In latest version we have to added it under /etc/sysconfig/openfire

OPENFIRE_OPTS="-Xms256m -Xmx512m"

Thanks

You will need to cycle openfire to make it effective.

I asked about logging becuase you didn’t post any specific error - Next time that would be helpful.

I am using the TAR package of Openfire. The file I had to modify was /opt/openfire/bin/openfire