powered by Jive Software

Openfire stops working and no logging is possible

Hi,

i got some trouble with openfire 3.7.1.

I need to restart the Server at least once a week, because nobody can connect anymore.

The CPUload is pretty high, but no errors are found in the logfiles.

I have the broadcast and kraken plugin installed.

User are from Active directory.

So i decided to enable debugging. But the Debug windows stays empty and the logfile to.

I’ve added log.debug.enabled parameter and set it to true, but this doesnt help either.

the only log with some content is the info.log, but its rather short too:


2012.04.19 10:59:32 org.jivesoftware.openfire.pubsub.PubSubModule - Publish-Subscribe domain: pubsub.domain.de

2012.04.19 10:59:32 org.jivesoftware.openfire.muc.spi.MultiUserChatServiceImpl - Mehrbenutzerchat Domain domain: conference.domain.de

2012.04.19 10:59:33 org.jivesoftware.openfire.XMPPServer - Openfire 3.7.1 [19.04.2012 10:59:33]
2012.04.19 10:59:36 org.jivesoftware.openfire.container.AdminConsolePlugin - Adminkonsole lauscht auf:
http://domain.de:9090
https://domain.de:9091


can someone please help me?

greetings

Christian

1 Like

did you set xmpp.pep.enabled to false and cycle Openfire? Are there any memory errors logged to nohup.out?

thanks for the reply!

the log issue was actually a logrotate problem, i disabled log rotate for openfire and logging is fine now.

About the memory issue, i’ve already added the JVM option “-Xms256m -Xmx1024m”.

It worked longer, but now i got a memory error:

java.lang.OutOfMemoryError: GC overhead limit exceeded

I’ll try to disable pep, perhaps this helps.

1 Like

Hello I am using openfire 3.6.4 and I have mechanism for log files rotation, can you tell me how did you stopped the openfire’s log rotation?

You probably fixed this issue. But for future generations its quit simple. Set the size so large it will never reach it.

Edit /opt/openfire/conf/openfire.xml

and add

false # change to true to enable debug. or you can turn this on through the GUI.

10240000

true

10240000

10240000

And then restart the openfire service.