Openfire test settings not working ldap issues

Hi all I am trying to get a new openfire server up and running version 3.9.3

I had this working before with self signed certs, ms sql and ldap integrated signin. While trying to solve an ssl issue on my server I went in to server properties and changed host name under Server > Server Manager > Server Information > Edit properties button > and changed server name from what was there (local servers name) to the url/domain my IM system will be using. Since rebooting and starting services over I cannot log into my openfire server via the web portal.

I’ve been here before and went into the xml file and changed setup from true to false and went through the settings thinking I could just update the admins at the end of the process but no dice. No matter how I type the username in it says no username was provided or the specified username was not found. I cant tell if i have messed something up in the ldap config because the test settings button on all 3 browsers I have DOES NOT WORK so I dont know if that’s 100% right anymore. No combination of username notation gets me past that last screen. Nor does tweaking the ldap settings get me anywhere.

Tired of the guess and check method, since this is not production YET I decided to uninstall the service, uninstall the server software, delete the preexisting openfire directory in program files (x8, reboot reinstall, re add service and rerun the setup but to no avail, I CANNOT get past the last screen of add admins. I’ve used IE9, Firefox 35 and chrome 39.0.2171.95 and the test settings button does NOTHING. Very frustrating. Need advice please…

Thank you

stderror.log shows javax.naming.CommunicationException: simple bind failed: domaincontrollername:389 [Root exception is Connection reset]

So it likely is a ldap config issue. Still need advice on how to tweak this without testsettings button not working!

I figured out after hours that SSL was checked but still using port 389, I switched it to port 636 and it still fails with the same error. I checked my DC’s firewall policy and also did a port scan, 636 is open to local trafic which this is. After turning off SSL to LDAP and setting port to 389 I am authenticating again.

I still would really like SSL over LDAP on port 636 to work… Any tips? Thanks!