Openfire Thru Firewall, Spark has no roster?

Hey Everyone,

I am an Openfire/Spark n00b, have set it all up in an office environment with LDAP (AD) and groups, along with the Vcard/avatar patch.

Inside the office, it works smooth as silk (single private 10.x.x.x subnet, server is on the same subnet) all users log in and get the shared roster. (BTW: this thing is really great!, converted from Exchange2000 MSN setup)

Here’'s the problem:

I passed TCP port 5222 through the firewall (Cisco ACL/NAT) direct to the server, I can set up a spark client from a public IP no problem, I can search users, I can send and receive messages.

BUT I never get the roster from the server?

HELP! It’'s driving me nuts.

FYI: I also made a PPTP VPN connection (putting my remote machine onto the same 10.x.x.x subnet with all ports being passed to the remote network) and the same problem occurs. (No published Roster)

Please help me before the razor severs the artery.



If I manually create a roster from a machine on a public ip, log off, go to another machine on a public IP, log in with the same account, I get the manual roster I created on the first client.

Still, no sign of my server-shared roster.

Message was edited by: TimothyCox

Hi Tim,

is your xmpp.domain a DNS name which is resolvable public? I wonder if the server has a routing problem, do you see errors in the log files?


This problem just decided to go away, No reason, nothing changed, it just went away.

No points to award.

What ports did you open when you set this up?

I’m having a heck of a time getting it to work when spark is outside of the firewall.

Hi Joe,

port 5222 is the only one you need to open.


Hi, folks. Just googled this page.

Five years gone, I am face\ing the same problem, OpenFire 3.6.4 on Linux in the corporate network, Spark 2.5.8 outside. Port 5222 TCP is mapped via Kerio Winroute from Internet to OpenFire server (named “jabber”) inside the network. When I try to connect from the Interner, Spark says its got connected, but the roster is empty, see screenshot of the debug window in the attachment.

OpenFire admin console also says that user from outside Spark is connected, but other users don’t see it online and this user cannot receive any message.

Help, please.

I moved to Miranda and solved this problem by turning on XMPP compression in Jabber plugin. Now I have to move to Linux and Pidgin, the problem persists. I have created a ticket:

Pidgin developers say, the server stops responding when traffic is not compressed and the problem is in the misconfigured server. There are several logs on the ticket page and the screenshot of Miranda options. What else can help?